ncurses: add host build for 'tic'
[openwrt/openwrt.git] / package / libs / ncurses / Makefile
index 5d6e8fe2abc00e7920f241c4d55d1321cf4bdffd..3e087f9497927ad9b5207ea03df668ea3e02cad9 100644 (file)
@@ -22,7 +22,10 @@ PKG_LICENSE_FILES:=README
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
+PKG_BUILD_DEPENDS:=ncurses/host
+
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 
 define Package/libncurses
   SECTION:=libs
@@ -58,8 +61,10 @@ CONFIGURE_ARGS += \
        --disable-rpath \
        --without-ada \
        --without-debug \
+       --without-manpages \
        --without-profile \
        --without-progs \
+       --without-tests \
        --disable-big-core \
        --disable-home-terminfo \
        --with-normal \
@@ -67,6 +72,17 @@ CONFIGURE_ARGS += \
        --with-terminfo-dirs=/usr/share/terminfo \
        --with-default-terminfo-dir=/usr/share/terminfo
 
+HOST_CONFIGURE_ARGS += \
+       --without-cxx \
+       --without-cxx-binding \
+       --without-ada \
+       --without-debug \
+       --without-manpages \
+       --without-profile \
+       --without-tests \
+       --without-curses-h
+
+
 ifeq ($(HOST_OS),FreeBSD)
        CONFIGURE_ARGS +=
                --with-terminfo=/usr/share/terminfo.db 
@@ -149,6 +165,17 @@ define Build/InstallDev
 endef
 endif
 
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) libs
+       $(MAKE) -C $(HOST_BUILD_DIR)/progs tic
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/progs/tic $(STAGING_DIR_HOST)/bin/tic
+endef
+
+$(eval $(call HostBuild))
 $(eval $(call BuildPackage,terminfo))
 $(eval $(call BuildPackage,libncurses))
 $(eval $(call BuildPackage,libncursesw))