openssl: add option to omit deprecated APIs
[openwrt/openwrt.git] / package / libs / openssl / Makefile
index 0d86223..eb2dfff 100644 (file)
@@ -32,7 +32,8 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_OPENSSL_WITH_EC \
        CONFIG_OPENSSL_WITH_EC2M \
        CONFIG_OPENSSL_WITH_SSL3 \
-       CONFIG_OPENSSL_HARDWARE_SUPPORT
+       CONFIG_OPENSSL_HARDWARE_SUPPORT \
+       CONFIG_OPENSSL_WITH_DEPRECATED
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -119,6 +120,10 @@ ifndef CONFIG_OPENSSL_HARDWARE_SUPPORT
   OPENSSL_OPTIONS += no-hw
 endif
 
+ifndef CONFIG_OPENSSL_WITH_DEPRECATED
+  OPENSSL_OPTIONS += no-deprecated
+endif
+
 ifeq ($(CONFIG_x86_64),y)
   OPENSSL_TARGET:=linux-x86_64-openwrt
   OPENSSL_MAKEFLAGS += LIBDIR=lib