popt: Replace dead upstream site with mirror
[openwrt/openwrt.git] / package / libs / popt / Makefile
index 1cdcc409b5342461210a4db53d1b686cce01f3aa..8e05e5cff2107b126f1108b3f486f723a4c6eb59 100644 (file)
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=popt
-PKG_VERSION:=1.7
-PKG_RELEASE:=5
+PKG_VERSION:=1.16
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
-PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
+PKG_SOURCE_URL:=http://distfiles.gentoo.org/distfiles/ http://distcache.freebsd.org/ports-distfiles/
+PKG_HASH:=e728ed296fe9f069a0e005003c3d6b2dde3d9cad453422a10d6558616d304cc8
+PKG_LICENSE:=MIT
 
 PKG_FIXUP:=autoreconf
 PKG_REMOVE_FILES:=autogen.sh aclocal.m4
@@ -44,6 +45,8 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/popt.h $(1)/usr/include/
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.{a,so*} $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/popt.pc $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libpopt/install
@@ -51,9 +54,5 @@ define Package/libpopt/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpopt.so.* $(1)/usr/lib/
 endef
 
-$(eval $(call RequireCommand,xgettext, \
-       $(PKG_NAME) requires the GNU gettext development package installed on the local system to build. \
-))
-
 $(eval $(call BuildPackage,libpopt))