pass the CFLAGS through the environment on compile and fix a few packages
[openwrt/openwrt.git] / package / linux-atm / Makefile
index 9aae0a0b0ed1a4f0b59aedaf1ca5b3811156affe..7691c1149a14da5f7c2ef86d4af46efa96fe4628 100644 (file)
@@ -51,11 +51,12 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
+TARGET_CFLAGS := -I$(PKG_BUILD_DIR)/src/include $(TARGET_CFLAGS)
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               all install
 endef
 
 define Build/InstallDev