fix mac80211 compile
[openwrt/openwrt.git] / package / mac80211 / Makefile
index 800ae48994e09e84f28d40291adc7e7ec3b14de0..8a387b445a4b73332c925747159e9164f1937451 100644 (file)
@@ -13,9 +13,6 @@ PKG_NAME:=mac80211
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
-  include $(LINUX_DIR)/.config
-endif
 
 define KernelPackage/mac80211
   SUBMENU:=Wireless Drivers
@@ -43,8 +40,9 @@ MAKE_OPTS:= \
        ARCH="$(LINUX_KARCH)" \
        EXTRA_CFLAGS="$(BUILDFLAGS)" \
        $(foreach opt,$(CONFOPTS),CONFIG_$(opt)=m) \
+       CONFIG_NL80211=y \
        CONFIG_MAC80211_LEDS=$(CONFIG_LEDS_TRIGGERS) \
-       LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h"
+       LINUXINCLUDE="-I${CURDIR}/src/include -I$(LINUX_DIR)/include -include linux/autoconf.h" \
 
 ifneq ($(findstring 2.6.23,$(LINUX_VERSION)),)
   define Build/Prepare