mac80211: update to wireless-testing 2012-02-06
[openwrt/openwrt.git] / package / mac80211 / patches / 400-ath_move_debug_code.patch
index c322dd3e5b3491e38e22aaab4307269f65a5e38a..69bb0f68068d1374978cd1fafd5245adffd13d7f 100644 (file)
@@ -1,17 +1,18 @@
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
 --- a/drivers/net/wireless/ath/Makefile
 +++ b/drivers/net/wireless/ath/Makefile
-@@ -8,6 +8,5 @@ obj-$(CONFIG_ATH_COMMON)       += ath.o
+@@ -8,7 +8,7 @@ obj-$(CONFIG_ATH_COMMON)       += ath.o
  ath-objs :=   main.o \
                regd.o \
                hw.o \
 -              key.o
  ath-objs :=   main.o \
                regd.o \
                hw.o \
 -              key.o
--
--ath-$(CONFIG_ATH_DEBUG) += debug.o
 +              key.o \
 +              debug.o
 +              key.o \
 +              debug.o
+-ath-$(CONFIG_ATH_DEBUG) += debug.o
+ ccflags-y += -D__CHECK_ENDIAN__
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
 --- a/drivers/net/wireless/ath/ath.h
 +++ b/drivers/net/wireless/ath/ath.h
-@@ -272,13 +272,6 @@ void ath_dbg(struct ath_common *common, 
+@@ -281,13 +281,6 @@ void _ath_dbg(struct ath_common *common,
  #endif /* CONFIG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */
  #endif /* CONFIG_ATH_DEBUG */
  
  /** Returns string describing opmode, or NULL if unknown mode. */