update to latest madwifi snapshot - fixes some noderef bugs
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index 9daeb90e9dfdf844d531b208ebedff8e1fcd95c8..3497b78cf49a58eb3825a7b18d6f9084c4519361 100644 (file)
@@ -1,28 +1,72 @@
-diff -urN madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c
---- madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c        2007-05-13 18:17:56.449987336 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c        2007-05-13 18:17:56.457986120 +0200
-@@ -75,7 +75,7 @@
- #include <net80211/if_llc.h>
- #endif
+Index: madwifi-ng-r2978-20071127/ath/if_ath.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/ath/if_ath.c        2007-11-27 21:43:39.632991016 +0100
++++ madwifi-ng-r2978-20071127/ath/if_ath.c     2007-11-27 22:09:32.889506059 +0100
+@@ -67,7 +67,7 @@
+ #include "if_media.h"
+ #include "if_llc.h"
  
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
  
- #include "net80211/if_athproto.h"
- #include "if_athvar.h"
-@@ -359,7 +359,7 @@
-               ath_keyprint(sc, __func__, ix, hk, mac);        \
- } while (0)
- #else /* defined(AR_DEBUG) */
--#define       IFF_DUMPPKTS(sc, _m)    netif_msg_dumppkts(&sc->sc_ic)
-+#define       IFF_DUMPPKTS(sc, _m)    0
- #define       DPRINTF(sc, _m, _fmt, ...)
- #define       KEYPRINTF(sc, k, ix, mac)
- #endif /* defined(AR_DEBUG) */
-diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c
---- madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c        2007-04-09 23:08:06.000000000 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c        2007-05-13 18:17:56.457986120 +0200
-@@ -69,7 +69,7 @@
+ #include <net80211/ieee80211_var.h>
+ #include <net80211/ieee80211_radiotap.h>
+@@ -535,9 +535,11 @@
+       u_int8_t csz;
+       sc->devid = devid;
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       DPRINTF(sc, ATH_DEBUG_ANY, "%s: devid 0x%x\n", __func__, devid);
++#endif
+       /*
+        * Cache line size is used to size and align various
+@@ -1268,12 +1270,14 @@
+               /* If no default VAP debug flags are passed, allow a few to
+                * transfer down from the driver to new VAPs so we can have load
+                * time debugging for VAPs too. */
++#ifdef AR_DEBUG
+               vap->iv_debug = 0 |
+                       ((sc->sc_debug & ATH_DEBUG_RATE) ? IEEE80211_MSG_XRATE  : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_XMIT) ? IEEE80211_MSG_OUTPUT : 0) | 
+                       ((sc->sc_debug & ATH_DEBUG_RECV) ? IEEE80211_MSG_INPUT  : 0) |
+                       0
+                       ;
++#endif
+       }
+       ic->ic_debug = (sc->sc_default_ieee80211_debug & IEEE80211_MSG_IC);
+@@ -9872,9 +9876,11 @@
+                               /* XXX validate? */
+                               sc->sc_ledpin = val;
+                               break;
++#ifdef AR_DEBUG
+                       case ATH_DEBUG:
+                               sc->sc_debug     = (val & ~ATH_DEBUG_GLOBAL);
+                               ath_debug_global = (val &  ATH_DEBUG_GLOBAL);
++#endif
+                               break;
+                       case ATH_TXANTENNA:
+                               /*
+@@ -10183,9 +10189,11 @@
+       }
+       /* initialize values */
++#ifdef AR_DEBUG
+       ath_debug_global = (ath_debug & ATH_DEBUG_GLOBAL);
+       sc->sc_debug     = (ath_debug & ~ATH_DEBUG_GLOBAL);
+       sc->sc_default_ieee80211_debug = ieee80211_debug;
++#endif
+       sc->sc_txantenna = 0;           /* default to auto-selection */
+       sc->sc_txintrperiod = ATH_TXQ_INTR_PERIOD;
+ }
+Index: madwifi-ng-r2978-20071127/ath_rate/amrr/amrr.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/ath_rate/amrr/amrr.c        2007-10-31 06:39:41.000000000 +0100
++++ madwifi-ng-r2978-20071127/ath_rate/amrr/amrr.c     2007-11-27 21:47:06.136758995 +0100
+@@ -70,7 +70,7 @@
  
  #include "amrr.h"
  
@@ -31,22 +75,24 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c madwifi-ng
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c
---- madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c        2007-05-13 18:17:55.605115776 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c        2007-05-13 18:17:56.458985968 +0200
+Index: madwifi-ng-r2978-20071127/ath_rate/minstrel/minstrel.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/ath_rate/minstrel/minstrel.c        2007-11-27 21:18:24.882670317 +0100
++++ madwifi-ng-r2978-20071127/ath_rate/minstrel/minstrel.c     2007-11-27 21:47:06.140759225 +0100
 @@ -117,7 +117,7 @@
  #include "minstrel.h"
  
- /* XXX: Use standard debug functions */
--#define       MINSTREL_DEBUG 10
+-#define       MINSTREL_DEBUG
 +#undef        MINSTREL_DEBUG
  #ifdef MINSTREL_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c
---- madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c        2007-04-09 23:08:06.000000000 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c        2007-05-13 18:17:56.458985968 +0200
-@@ -65,7 +65,7 @@
+               ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+Index: madwifi-ng-r2978-20071127/ath_rate/onoe/onoe.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/ath_rate/onoe/onoe.c        2007-10-31 06:39:41.000000000 +0100
++++ madwifi-ng-r2978-20071127/ath_rate/onoe/onoe.c     2007-11-27 21:47:06.144759451 +0100
+@@ -66,7 +66,7 @@
  
  #include "onoe.h"
  
@@ -55,10 +101,11 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c madwifi-ng
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c
---- madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c    2007-04-09 23:08:06.000000000 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c    2007-05-13 18:17:56.459985816 +0200
-@@ -67,7 +67,7 @@
+Index: madwifi-ng-r2978-20071127/ath_rate/sample/sample.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/ath_rate/sample/sample.c    2007-11-21 09:23:20.000000000 +0100
++++ madwifi-ng-r2978-20071127/ath_rate/sample/sample.c 2007-11-27 21:47:06.148759680 +0100
+@@ -68,7 +68,7 @@
  
  #include "sample.h"
  
@@ -66,58 +113,11 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c madwif
 +#undef        SAMPLE_DEBUG
  #ifdef SAMPLE_DEBUG
  enum {
-       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c
---- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c  2007-02-01 21:49:37.000000000 +0100
-+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c  2007-05-13 18:17:56.460985664 +0200
-@@ -312,6 +312,7 @@
- }
- EXPORT_SYMBOL(ieee80211_print_essid);
-+#ifdef IEEE80211_DEBUG
- void
- ieee80211_dump_pkt(struct ieee80211com *ic,
-       const u_int8_t *buf, int len, int rate, int rssi)
-@@ -390,6 +391,7 @@
-       }
- }
- EXPORT_SYMBOL(ieee80211_dump_pkt);
-+#endif /* IEEE80211_DEBUG */
- int
- ieee80211_fix_rate(struct ieee80211_node *ni, int flags)
-diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h
---- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h  2007-01-30 05:01:29.000000000 +0100
-+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h  2007-05-13 18:17:56.460985664 +0200
-@@ -247,7 +247,11 @@
- #endif
- int ieee80211_new_state(struct ieee80211vap *, enum ieee80211_state, int);
- void ieee80211_print_essid(const u_int8_t *, int);
-+#ifdef IEEE80211_DEBUG
- void ieee80211_dump_pkt(struct ieee80211com *, const u_int8_t *, int, int, int);
-+#else
-+#define ieee80211_dump_pkt(...)
-+#endif
- struct sk_buff *ieee80211_getcfframe(struct ieee80211vap *, int);
- /*
-diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h
---- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h    2007-05-13 18:17:56.107039472 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h    2007-05-13 18:17:56.461985512 +0200
-@@ -35,8 +35,8 @@
- #ifndef _NET80211_IEEE80211_VAR_H_
- #define _NET80211_IEEE80211_VAR_H_
--#define       IEEE80211_DEBUG
--#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
-+#undef        IEEE80211_DEBUG
-+#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
- /* Definitions for IEEE 802.11 drivers. */
- #include <net80211/ieee80211_linux.h>
-diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c
---- madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c    2007-05-13 18:17:55.192178552 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c    2007-05-13 18:17:56.461985512 +0200
+       ATH_DEBUG_RATE          = 0x00000010,   /* rate control */
+Index: madwifi-ng-r2978-20071127/tools/do_multi.c
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/tools/do_multi.c    2007-11-27 21:18:24.826667124 +0100
++++ madwifi-ng-r2978-20071127/tools/do_multi.c 2007-11-27 21:47:06.152759909 +0100
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -139,24 +139,40 @@ diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c madwifi-ng-ref
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/Makefile madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile
---- madwifi-ng-refcount-r2313-20070505.old/tools/Makefile      2007-05-13 18:17:55.192178552 +0200
-+++ madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile      2007-05-13 18:17:56.461985512 +0200
-@@ -52,7 +52,7 @@
-       
- ifdef DOMULTI
- OBJS= do_multi.o athstats.o 80211stats.o athkey.o athchans.o athctrl.o \
--      athdebug.o 80211debug.o wlanconfig.o 
-+      wlanconfig.o 
- ALL=  ${OBJS} madwifi_multi
- endif
+Index: madwifi-ng-r2978-20071127/tools/Makefile
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/tools/Makefile      2007-11-27 21:18:24.826667124 +0100
++++ madwifi-ng-r2978-20071127/tools/Makefile   2007-11-27 21:47:06.152759909 +0100
+@@ -48,7 +48,7 @@
  
-@@ -85,7 +85,7 @@
+ ALLPROGS=     athstats 80211stats athkey athchans athctrl \
+-      athdebug 80211debug wlanconfig ath_info
++      wlanconfig ath_info
+ OBJS= $(patsubst %,%.o,$(ALLPROGS) do_multi)
+ ALL=  ${OBJS} madwifi_multi
+@@ -84,7 +84,7 @@
        ${CC} -c -o do_multi.o -DDOMULTI=1 ${ALL_CFLAGS} do_multi.c
- madwifi_multi:
+ madwifi_multi: $(OBJS)
        ${CC} -o madwifi_multi ${LDFLAGS} ${OBJS}
 -      for i in athstats 80211stats athkey athchans athctrl athdebug wlanconfig 80211debug; do \
 +      for i in athstats 80211stats athkey athchans athctrl wlanconfig; do \
        ln -s -f madwifi_multi $$i; \
        done
  
+Index: madwifi-ng-r2978-20071127/net80211/ieee80211_linux.h
+===================================================================
+--- madwifi-ng-r2978-20071127.orig/net80211/ieee80211_linux.h  2007-11-27 21:47:46.371051817 +0100
++++ madwifi-ng-r2978-20071127/net80211/ieee80211_linux.h       2007-11-27 21:47:56.199611915 +0100
+@@ -29,8 +29,8 @@
+ #ifndef _NET80211_IEEE80211_LINUX_H_
+ #define _NET80211_IEEE80211_LINUX_H_
+-#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
++#undef        IEEE80211_DEBUG
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
+ /* #define ATH_DEBUG_SPINLOCKS */             /* announce before spinlocking */
+ #include <linux/wireless.h>