package/madwifi: refresh madwifi patches
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index 5e5eb04547f77f7dacd297fe4e59a07f859a076f..3f46ec88b46bfbd38b1e88c927e7e9b549e695b0 100644 (file)
@@ -43,7 +43,7 @@
        ic->ic_set_dfs_testmode     = ath_set_dfs_testmode;
        ic->ic_get_dfs_testmode     = ath_get_dfs_testmode;
  
-@@ -1297,12 +1301,14 @@ ath_vap_create(struct ieee80211com *ic, 
+@@ -1297,12 +1301,14 @@ ath_vap_create(struct ieee80211com *ic,
                /* If no default VAP debug flags are passed, allow a few to
                 * transfer down from the driver to new VAPs so we can have load
                 * time debugging for VAPs too. */
      if(strcmp(progname, "athstats") == 0)
 --- a/tools/Makefile
 +++ b/tools/Makefile
-@@ -48,6 +48,8 @@ endif
+@@ -48,14 +48,16 @@ endif
  
  all: compile
  
 +DEBUG = -DAR_DEBUG
 +
  ALLPROGS=     athstats 80211stats athkey athchans athctrl \
-       athdebug 80211debug wlanconfig ath_info
+-      athdebug 80211debug wlanconfig ath_info
++      $(if $(DEBUG),athdebug 80211debug) wlanconfig ath_info
  
-@@ -55,7 +57,7 @@ OBJS=        $(patsubst %,%.o,$(ALLPROGS))
+ OBJS= $(patsubst %,%.o,$(ALLPROGS))
  
  INCS= -I. -I../ath -I$(HAL) -I$(TOP) -I$(ATH_HAL)
  CFLAGS=       -g -O2 -Wall