huge madwifi update - use a madwifi-ng-refcount snapshot as base, includes lots of...
[openwrt/openwrt.git] / package / madwifi / patches / 200-no_debug.patch
index 350a66d4cae54f22684714a6dfe96cf211688007..9daeb90e9dfdf844d531b208ebedff8e1fcd95c8 100644 (file)
@@ -1,17 +1,17 @@
-diff -ur madwifi.old/ath/if_ath.c madwifi.dev/ath/if_ath.c
---- madwifi.old/ath/if_ath.c   2007-02-20 23:24:27.274770480 +0100
-+++ madwifi.dev/ath/if_ath.c   2007-02-20 23:26:49.917085552 +0100
-@@ -72,7 +72,7 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c
+--- madwifi-ng-refcount-r2313-20070505.old/ath/if_ath.c        2007-05-13 18:17:56.449987336 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/ath/if_ath.c        2007-05-13 18:17:56.457986120 +0200
+@@ -75,7 +75,7 @@
  #include <net80211/if_llc.h>
  #endif
  
 -#define       AR_DEBUG
 +#undef        AR_DEBUG
  
- #include "if_athrate.h"
  #include "net80211/if_athproto.h"
-@@ -347,7 +347,7 @@
-               ath_keyprint(__func__, ix, hk, mac);            \
+ #include "if_athvar.h"
+@@ -359,7 +359,7 @@
+               ath_keyprint(sc, __func__, ix, hk, mac);        \
  } while (0)
  #else /* defined(AR_DEBUG) */
 -#define       IFF_DUMPPKTS(sc, _m)    netif_msg_dumppkts(&sc->sc_ic)
@@ -19,10 +19,10 @@ diff -ur madwifi.old/ath/if_ath.c madwifi.dev/ath/if_ath.c
  #define       DPRINTF(sc, _m, _fmt, ...)
  #define       KEYPRINTF(sc, k, ix, mac)
  #endif /* defined(AR_DEBUG) */
-diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
---- madwifi.old/ath_rate/amrr/amrr.c   2007-02-20 23:24:27.274770480 +0100
-+++ madwifi.dev/ath_rate/amrr/amrr.c   2007-02-20 23:23:54.714720360 +0100
-@@ -67,7 +67,7 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c
+--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/amrr/amrr.c        2007-04-09 23:08:06.000000000 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/amrr/amrr.c        2007-05-13 18:17:56.457986120 +0200
+@@ -69,7 +69,7 @@
  
  #include "amrr.h"
  
@@ -31,10 +31,22 @@ diff -ur madwifi.old/ath_rate/amrr/amrr.c madwifi.dev/ath_rate/amrr/amrr.c
  #ifdef AMRR_DEBUG
  #define       DPRINTF(sc, _fmt, ...) do {                                     \
        if (sc->sc_debug & 0x10)                                        \
-diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
---- madwifi.old/ath_rate/onoe/onoe.c   2007-02-20 23:24:27.275770328 +0100
-+++ madwifi.dev/ath_rate/onoe/onoe.c   2007-02-20 23:23:54.714720360 +0100
-@@ -63,7 +63,7 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c
+--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/minstrel/minstrel.c        2007-05-13 18:17:55.605115776 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/minstrel/minstrel.c        2007-05-13 18:17:56.458985968 +0200
+@@ -117,7 +117,7 @@
+ #include "minstrel.h"
+ /* XXX: Use standard debug functions */
+-#define       MINSTREL_DEBUG 10
++#undef        MINSTREL_DEBUG
+ #ifdef MINSTREL_DEBUG
+ enum {
+       ATH_DEBUG_RATE          = 0x00000010    /* rate control */
+diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c
+--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/onoe/onoe.c        2007-04-09 23:08:06.000000000 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/onoe/onoe.c        2007-05-13 18:17:56.458985968 +0200
+@@ -65,7 +65,7 @@
  
  #include "onoe.h"
  
@@ -43,10 +55,10 @@ diff -ur madwifi.old/ath_rate/onoe/onoe.c madwifi.dev/ath_rate/onoe/onoe.c
  #ifdef ONOE_DEBUG
  enum {
        ATH_DEBUG_RATE  = 0x00000010,   /* rate control */
-diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample.c
---- madwifi.old/ath_rate/sample/sample.c       2007-02-20 23:24:27.275770328 +0100
-+++ madwifi.dev/ath_rate/sample/sample.c       2007-02-20 23:23:54.715720208 +0100
-@@ -65,7 +65,7 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c
+--- madwifi-ng-refcount-r2313-20070505.old/ath_rate/sample/sample.c    2007-04-09 23:08:06.000000000 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/ath_rate/sample/sample.c    2007-05-13 18:17:56.459985816 +0200
+@@ -67,7 +67,7 @@
  
  #include "sample.h"
  
@@ -55,10 +67,10 @@ diff -ur madwifi.old/ath_rate/sample/sample.c madwifi.dev/ath_rate/sample/sample
  #ifdef SAMPLE_DEBUG
  enum {
        ATH_DEBUG_RATE          = 0x00000010    /* rate control */
-diff -ur madwifi.old/net80211/ieee80211_proto.c madwifi.dev/net80211/ieee80211_proto.c
---- madwifi.old/net80211/ieee80211_proto.c     2007-02-20 23:23:54.682725000 +0100
-+++ madwifi.dev/net80211/ieee80211_proto.c     2007-02-20 23:26:03.244180912 +0100
-@@ -307,6 +307,7 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c
+--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.c  2007-02-01 21:49:37.000000000 +0100
++++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.c  2007-05-13 18:17:56.460985664 +0200
+@@ -312,6 +312,7 @@
  }
  EXPORT_SYMBOL(ieee80211_print_essid);
  
@@ -66,7 +78,7 @@ diff -ur madwifi.old/net80211/ieee80211_proto.c madwifi.dev/net80211/ieee80211_p
  void
  ieee80211_dump_pkt(struct ieee80211com *ic,
        const u_int8_t *buf, int len, int rate, int rssi)
-@@ -385,6 +386,7 @@
+@@ -390,6 +391,7 @@
        }
  }
  EXPORT_SYMBOL(ieee80211_dump_pkt);
@@ -74,10 +86,10 @@ diff -ur madwifi.old/net80211/ieee80211_proto.c madwifi.dev/net80211/ieee80211_p
  
  int
  ieee80211_fix_rate(struct ieee80211_node *ni, int flags)
-diff -ur madwifi.old/net80211/ieee80211_proto.h madwifi.dev/net80211/ieee80211_proto.h
---- madwifi.old/net80211/ieee80211_proto.h     2006-06-10 04:17:05.000000000 +0200
-+++ madwifi.dev/net80211/ieee80211_proto.h     2007-02-20 23:27:28.791175792 +0100
-@@ -246,7 +246,11 @@
+diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h
+--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_proto.h  2007-01-30 05:01:29.000000000 +0100
++++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_proto.h  2007-05-13 18:17:56.460985664 +0200
+@@ -247,7 +247,11 @@
  #endif
  int ieee80211_new_state(struct ieee80211vap *, enum ieee80211_state, int);
  void ieee80211_print_essid(const u_int8_t *, int);
@@ -89,21 +101,23 @@ diff -ur madwifi.old/net80211/ieee80211_proto.h madwifi.dev/net80211/ieee80211_p
  struct sk_buff *ieee80211_getcfframe(struct ieee80211vap *, int);
  
  /*
-diff -ur madwifi.old/net80211/ieee80211_var.h madwifi.dev/net80211/ieee80211_var.h
---- madwifi.old/net80211/ieee80211_var.h       2007-02-20 23:24:27.276770176 +0100
-+++ madwifi.dev/net80211/ieee80211_var.h       2007-02-20 23:23:54.715720208 +0100
-@@ -37,7 +37,7 @@
- /*
-  * Definitions for IEEE 802.11 drivers.
-  */
+diff -urN madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h
+--- madwifi-ng-refcount-r2313-20070505.old/net80211/ieee80211_var.h    2007-05-13 18:17:56.107039472 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/net80211/ieee80211_var.h    2007-05-13 18:17:56.461985512 +0200
+@@ -35,8 +35,8 @@
+ #ifndef _NET80211_IEEE80211_VAR_H_
+ #define _NET80211_IEEE80211_VAR_H_
 -#define       IEEE80211_DEBUG
+-#define       IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
 +#undef        IEEE80211_DEBUG
- #undef        IEEE80211_DEBUG_REFCNT                  /* node refcnt stuff */
++#undef        IEEE80211_DEBUG_REFCNT                  /* Node reference count debugging */
  
+ /* Definitions for IEEE 802.11 drivers. */
  #include <net80211/ieee80211_linux.h>
-diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
---- madwifi.old/tools/do_multi.c       2007-02-20 23:24:27.276770176 +0100
-+++ madwifi.dev/tools/do_multi.c       2007-02-20 23:23:54.715720208 +0100
+diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c
+--- madwifi-ng-refcount-r2313-20070505.old/tools/do_multi.c    2007-05-13 18:17:55.192178552 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/tools/do_multi.c    2007-05-13 18:17:56.461985512 +0200
 @@ -9,16 +9,20 @@
  
      progname = basename(argv[0]);
@@ -125,9 +139,9 @@ diff -ur madwifi.old/tools/do_multi.c madwifi.dev/tools/do_multi.c
      if(strcmp(progname, "athkey") == 0)
        ret =  athkey_init(argc, argv);
      if(strcmp(progname, "athstats") == 0)
-diff -ur madwifi.old/tools/Makefile madwifi.dev/tools/Makefile
---- madwifi.old/tools/Makefile 2007-02-20 23:24:27.276770176 +0100
-+++ madwifi.dev/tools/Makefile 2007-02-20 23:23:54.716720056 +0100
+diff -urN madwifi-ng-refcount-r2313-20070505.old/tools/Makefile madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile
+--- madwifi-ng-refcount-r2313-20070505.old/tools/Makefile      2007-05-13 18:17:55.192178552 +0200
++++ madwifi-ng-refcount-r2313-20070505.dev/tools/Makefile      2007-05-13 18:17:56.461985512 +0200
 @@ -52,7 +52,7 @@
        
  ifdef DOMULTI