ltq-vdsl-app: load the vrx200 firmware or patch it
[openwrt/openwrt.git] / package / network / config / ltq-vdsl-app / Makefile
index da2451b8bce8c1bae8d736e9ff63d74f63d20f5c..ffaf942e54fdf720478759782d6a5b099b9f8374 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=ltq-vdsl-app
 PKG_VERSION:=4.16.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_BASE_NAME:=dsl_cpe_control
 PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
@@ -34,30 +34,25 @@ define Package/ltq-vdsl-app/description
 endef
 
 CONFIGURE_ARGS += \
-       --with-max-device="1" \
-       --with-lines-per-device="1" \
-       --with-channels-per-line="1" \
        --enable-vrx \
+       --enable-vrx-device=vr9 \
        --enable-driver-include="-I$(STAGING_DIR)/usr/include/drv_vdsl_cpe_api" \
        --enable-device-driver-include="-I$(STAGING_DIR)/usr/include/vdsl/" \
-       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
        --enable-ifxos \
        --enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos" \
        --enable-ifxos-library="-I$(STAGING_DIR)/usr/lib" \
-       --enable-dsl-ceoc=no \
-       --enable-vrx-device=vr9 \
+       --enable-add-appl-cflags="-DMAX_CLI_PIPES=1"  \
+       --enable-debug \
        --disable-dti \
-       --enable-debug
-
-ifeq ($(CONFIG_IFX_CLI),y)
-CONFIGURE_ARGS += \
-       --enable-cli-support
-endif
+       --with-channels-per-line="1" \
 
 #CONFIGURE_ARGS += --enable-model=full
 #CONFIGURE_ARGS += --enable-model=lite
 #CONFIGURE_ARGS += --enable-model=footprint
-CONFIGURE_ARGS += --enable-model=typical
+CONFIGURE_ARGS += \
+       --enable-model=typical \
+       --enable-dsl-pm-showtime \
+       --disable-dsl-ceoc
 #CONFIGURE_ARGS += --enable-model=debug
 
 define Package/ltq-vdsl-app/install