netifd: fix deletion of ip tunnels (FS#4058)
[openwrt/openwrt.git] / package / network / config / netifd / Makefile
index bb9ba2fea1674c33338c94d4ff97222bf6b11c83..f9aea470cd41af774039e84a8d5235f27e620138 100644 (file)
@@ -1,13 +1,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=netifd
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL=$(PROJECT_GIT)/project/netifd.git
-PKG_SOURCE_DATE:=2018-01-24
-PKG_SOURCE_VERSION:=af3cadb6a46ba93e8a729e71d82b176275931e62
-PKG_MIRROR_HASH:=66722c55bcf8a145a7c1b7291306271dc5996e9adbac0c7a01a693fe15cbe053
+PKG_SOURCE_DATE:=2021-11-27
+PKG_SOURCE_VERSION:=a68e80513abb73cc76b94b5d70d0813344fa7cd7
+PKG_MIRROR_HASH:=4f2eff7a0bd4e9b278d220a4361e8948b582feab59eeedcc5eb120678aa72d0d
 PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_LICENSE:=GPL-2.0
@@ -25,9 +25,17 @@ define Package/netifd
   TITLE:=OpenWrt Network Interface Configuration Daemon
 endef
 
+define Package/netifd/conffiles
+/etc/udhcpc.user
+/etc/udhcpc.user.d/
+endef
+
 TARGET_CFLAGS += \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
-       -I$(STAGING_DIR)/usr/include
+       -I$(STAGING_DIR)/usr/include \
+       -flto
+
+TARGET_LDFLAGS += -flto -fuse-linker-plugin
 
 CMAKE_OPTIONS += \
        -DLIBNL_LIBS=-lnl-tiny \
@@ -37,6 +45,7 @@ define Package/netifd/install
        $(INSTALL_DIR) $(1)/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/netifd $(1)/sbin/
        $(CP) ./files/* $(1)/
+       $(INSTALL_DIR) $(1)/etc/udhcpc.user.d/
        $(CP) $(PKG_BUILD_DIR)/scripts/* $(1)/lib/netifd/
 endef