map: depend on nat46, provide map-t
[openwrt/openwrt.git] / package / network / ipv6 / map / Makefile
index cfb7c4ac357e6f4942978611ac42c5ccb99024b9..5a18c7b01f05ebb5aa859313e429edfa8d41ea95 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=4
-PKG_RELEASE:=11
+PKG_RELEASE:=12
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
@@ -18,16 +18,17 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/map
   SECTION:=net
   CATEGORY:=Network
-  DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra
-  TITLE:=MAP-E and Lightweight 4over6 configuration support
+  DEPENDS:=@IPV6 +kmod-ip6-tunnel +libubox +libubus +iptables-mod-conntrack-extra +kmod-nat46
+  TITLE:=MAP-E/MAP-T and Lightweight 4over6 configuration support
   MAINTAINER:=Hans Dedecker <dedeckeh@gmail.com>
+  PROVIDES:=map-t
 endef
 
 define Package/map/description
- Provides support for MAP-E (draft-ietf-softwire-map) and
- Lightweight 4over6 (draft-ietf-softwire-lw4over6) in /etc/config/network.
- Refer to http://wiki.openwrt.org/doc/uci/network for
- configuration details.
+ Provides support for MAP-E (RFC7597), MAP-T (RFC7599) and
+ Lightweight 4over6 (RFC7596) in /etc/config/network.
+ MAP combines address and port translation with the tunneling
+ of IPv4 packets over an IPv6 network
 endef
 
 define Package/map/install