dnsmasq: Pass TARGET_CPPFLAGS to Makefile
[openwrt/openwrt.git] / package / network / services / dnsmasq / Makefile
index 8eed5427a40d8131bed710d68eedcb80a3839930..01c7191192bae2ebf23a7fcd7216625be7fd87d4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.78
-PKG_RELEASE:=2
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/
@@ -137,7 +137,7 @@ endif
 
 MAKE_FLAGS := \
        $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        COPTS="$(COPTS)" \
        PREFIX="/usr"