dropbear: compile with LTO enabled
[openwrt/openwrt.git] / package / network / services / dropbear / Makefile
index 742e538ff55668d059f5d4d9f88e647df09e12ec..515434dc2f3f953108eb8ebb343faa0cd45ffaaf 100644 (file)
@@ -86,8 +86,8 @@ CONFIGURE_ARGS += \
        $(if $(CONFIG_DROPBEAR_ZLIB),,--disable-zlib) \
        --enable-bundled-libtom
 
-TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
-TARGET_LDFLAGS += -Wl,--gc-sections
+TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto
+TARGET_LDFLAGS += -Wl,--gc-sections -flto=jobserver
 
 define Build/Configure
        $(Build/Configure/Default)