dropbear: clean up default PATH handling in makefile
[openwrt/openwrt.git] / package / network / services / dropbear / Makefile
index b80f4d5c81ca1627b46fa2fd2f75be27cff47bf6..faad41adf23be4e396e59de7b76c7d8673b48b87 100644 (file)
@@ -66,7 +66,6 @@ CONFIGURE_ARGS += \
        --disable-pam \
        --enable-openpty \
        --enable-syslog \
-       $(if $(CONFIG_SHADOW_PASSWORDS),,--disable-shadow) \
        --disable-lastlog \
        --disable-utmpx \
        $(if $(CONFIG_DROPBEAR_UTMP),,--disable-utmp) \
@@ -78,13 +77,13 @@ CONFIGURE_ARGS += \
        --disable-zlib \
        --enable-bundled-libtom
 
-TARGET_CFLAGS += -DDEFAULT_PATH=\\\"$(CONFIG_TARGET_INIT_PATH)\\\" -DARGTYPE=3 -ffunction-sections -fdata-sections
+TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 define Build/Configure
        $(Build/Configure/Default)
 
-       $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(CONFIG_TARGET_INIT_PATH)",g' \
+       $(SED) 's,^#define DEFAULT_PATH .*$$$$,#define DEFAULT_PATH "$(TARGET_INIT_PATH)",g' \
                $(PKG_BUILD_DIR)/options.h
 
        awk 'BEGIN { rc = 1 } \