hostapd: add hs20 variant
[openwrt/openwrt.git] / package / network / services / hostapd / Makefile
index 3aa17b4d3a036bc36a398cf01444bed2de6e4ed4..5e56a43e9a758647b45518bdb9a05e3c8a660299 100644 (file)
@@ -68,6 +68,9 @@ CONFIG_VARIANT:=$(LOCAL_VARIANT)
 ifeq ($(LOCAL_VARIANT),mesh)
   CONFIG_VARIANT:=full
 endif
+ifeq ($(LOCAL_VARIANT),hs20)
+  CONFIG_VARIANT:=full
+endif
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -108,6 +111,10 @@ ifeq ($(SSL_VARIANT),openssl)
   ifeq ($(LOCAL_VARIANT),full)
     DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y
   endif
+  ifeq ($(LOCAL_VARIANT),hs20)
+    DRIVER_MAKEOPTS += CONFIG_OWE=y CONFIG_SUITEB192=y CONFIG_AP=y CONFIG_MESH=y CONFIG_DPP=y CONFIG_HS20=y CONFIG_INTERWORKING=y
+  endif
+
 endif
 
 ifeq ($(SSL_VARIANT),wolfssl)
@@ -168,6 +175,15 @@ endef
 
 Package/hostapd-openssl/description = $(Package/hostapd/description)
 
+define Package/hostapd-hs20
+$(call Package/hostapd/Default,$(1))
+  TITLE+= (OpenSSL with Hotspot 2.0)
+  VARIANT:=hs20-openssl
+  DEPENDS+=+libopenssl
+endef
+
+Package/hostapd-hs20/description = $(Package/hostapd/description)
+
 define Package/hostapd-wolfssl
 $(call Package/hostapd/Default,$(1))
   TITLE+= (wolfSSL full)
@@ -453,7 +469,9 @@ define Build/Configure
        $(if $(wildcard ./files/hostapd-$(CONFIG_VARIANT).config), \
                $(CP) ./files/hostapd-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/hostapd/.config \
        )
-       $(CP) ./files/wpa_supplicant-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/wpa_supplicant/.config
+       $(if $(wildcard ./files/wpa_supplicant-$(CONFIG_VARIANT).config), \
+               $(CP) ./files/wpa_supplicant-$(CONFIG_VARIANT).config $(PKG_BUILD_DIR)/wpa_supplicant/.config
+       )
 endef
 
 TARGET_CPPFLAGS := \
@@ -567,6 +585,7 @@ define Package/hostapd/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
 endef
 Package/hostapd-basic/install = $(Package/hostapd/install)
+Package/hostapd-hs20/install = $(Package/hostapd/install)
 Package/hostapd-mini/install = $(Package/hostapd/install)
 Package/hostapd-openssl/install = $(Package/hostapd/install)
 Package/hostapd-wolfssl/install = $(Package/hostapd/install)
@@ -635,6 +654,7 @@ endif
 
 $(eval $(call BuildPackage,hostapd))
 $(eval $(call BuildPackage,hostapd-basic))
+$(eval $(call BuildPackage,hostapd-hs20))
 $(eval $(call BuildPackage,hostapd-mini))
 $(eval $(call BuildPackage,hostapd-openssl))
 $(eval $(call BuildPackage,hostapd-wolfssl))