lldpd: inhibit linking of libbsd on !GLIBC
[openwrt/openwrt.git] / package / network / services / lldpd / Makefile
index f038a340ac5f8c24de1ed0ef9ed6b72f7c9412d5..3605ed25f9232e3166205453c876eabfbacc3dd1 100644 (file)
@@ -8,21 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.7.13
+PKG_VERSION:=1.0.1
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=13e8be761753eac9a8e12128acba40b4
+PKG_SOURCE_URL:=https://media.luffy.cx/files/lldpd
+PKG_HASH:=450b622aac7ae1758f1ef82f3b7b94ec47f2ff33abfb0e6ac82555b9ee55f151
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Stijn Tintel <stijn@linux-ipv6.be>
 PKG_LICENSE:=ISC
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
-TARGET_CFLAGS+=--std=c99
-
 include $(INCLUDE_DIR)/package.mk
 
 define Package/lldpd
@@ -30,8 +28,8 @@ define Package/lldpd
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
-  URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+  URL:=https://vincentbernat.github.io/lldpd/
+  DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c +LLDPD_WITH_SNMP:libnetsnmp
   USERID:=lldp=121:lldp=129
   MENU:=1
 endef
@@ -49,6 +47,14 @@ define Package/lldpd/description
        Link-Layer notifications to adjacent network devices.
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/lldpd.d
@@ -57,7 +63,7 @@ define Package/lldpd/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/lldp{cli,ctl,d} $(1)/usr/sbin/
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
        $(INSTALL_BIN) ./files/lldpd.init $(1)/etc/init.d/lldpd
-       $(INSTALL_DATA) ./files/lldpd.config $(1)/etc/config/lldpd
+       $(INSTALL_CONF) ./files/lldpd.config $(1)/etc/config/lldpd
 ifneq ($(CONFIG_LLDPD_WITH_CDP),y)
        sed -i -e '/cdp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
 endif
@@ -70,26 +76,40 @@ endif
 ifneq ($(CONFIG_LLDPD_WITH_SONMP),y)
        sed -i -e '/sonmp/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
 endif
+ifneq ($(CONFIG_LLDPD_WITH_SNMP),y)
+       sed -i -e '/agentxsocket/d' $(1)/etc/init.d/lldpd $(1)/etc/config/lldpd
+endif
 endef
 
 define Package/lldpd/conffiles
 /etc/config/lldpd
 endef
 
+CONFIGURE_VARS += \
+       $(if $(CONFIG_USE_GLIBC),,libbsd_CFLAGS=-ldo-not-link-bsd) \
+       $(if $(CONFIG_USE_GLIBC),,libbsd_LDFLAGS=-ldo-not-link-bsd)
+
 CONFIGURE_ARGS += \
+       $(if $(CONFIG_LLDPD_WITH_PRIVSEP), \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
        --with-privsep-chroot=/var/run/lldp \
+       ,--disable-privsep) \
        --with-readline=no \
        --with-embedded-libevent=no \
+       --disable-hardening \
+       --without-xml \
+       --sysconfdir=/tmp \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
        $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
        $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
        $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+       $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
-       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no) \
+       $(if $(CONFIG_LLDPD_WITH_SNMP),--with-snmp,)
 
 
 $(eval $(call BuildPackage,lldpd))