odhcpd: various regression fixes (thanks Hans Dedecker)
[openwrt/openwrt.git] / package / network / services / odhcpd / Makefile
index 95939651f5d556d1e82dc6d4bc9739d2130c25d8..37b6156bc6c0f82bb4351de5bff2c29249ce9ccd 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcpd
-PKG_VERSION:=2014-01-22
+PKG_VERSION:=2014-06-10
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcpd.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=f0b46eb203e192f44d8f870f905697ae4612d111
+PKG_SOURCE_VERSION:=6c93cef912cc3f9b0bd0805bd66289d72bc315e5
 
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
@@ -23,10 +23,16 @@ include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 CMAKE_OPTIONS += -DUBUS=1
+
 ifneq ($(CONFIG_PACKAGE_odhcpd_ext_prefix_class),0)
   CMAKE_OPTIONS += -DEXT_PREFIX_CLASS=$(CONFIG_PACKAGE_odhcpd_ext_prefix_class)
 endif
 
+ifneq ($(CONFIG_PACKAGE_odhcpd_ext_cer_id),0)
+  CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcpd_ext_cer_id)
+endif
+
+
 define Package/odhcpd
   SECTION:=net
   CATEGORY:=Network
@@ -39,6 +45,10 @@ define Package/odhcpd/config
     int "Prefix Class Extension ID (0 = disabled)"
     depends on PACKAGE_odhcpd
     default 0
+  config PACKAGE_odhcpd_ext_cer_id
+    int "CER-ID Extension ID (0 = disabled)"
+    depends on PACKAGE_odhcpd
+    default 0
 endef
 
 define Package/odhcpd/description