openvpn: update to 2.4.5
[openwrt/openwrt.git] / package / network / services / openvpn / patches / 210-build_always_use_internal_lz4.patch
index d49e0bf9ec9f46df6a041a494059ea92cbdb8727..b3eb7c742af61a7b5ba0aa9f1c0abac41f97d66f 100644 (file)
@@ -1,15 +1,17 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -1068,62 +1068,15 @@ dnl
+@@ -1077,68 +1077,15 @@ dnl
  AC_ARG_VAR([LZ4_CFLAGS], [C compiler flags for lz4])
  AC_ARG_VAR([LZ4_LIBS], [linker flags for lz4])
  if test "$enable_lz4" = "yes" && test "$enable_comp_stub" = "no"; then
 -    if test -z "${LZ4_CFLAGS}" -a -z "${LZ4_LIBS}"; then
 -      # if the user did not explicitly specify flags, try to autodetect
 -      PKG_CHECK_MODULES([LZ4],
--                        [liblz4 >= 1.7.1],
+-                        [liblz4 >= 1.7.1 liblz4 < 100],
 -                        [have_lz4="yes"],
--                        [] # If this fails, we will do another test next
+-                        [LZ4_LIBS="-llz4"] # If this fails, we will do another test next.
+-                                           # We also add set LZ4_LIBS otherwise the
+-                                           # linker will not know about the lz4 library
 -      )
 -    fi
 
 -      fi
 -    fi
 -
--    # if LZ4_LIBS is set, we assume it will work, otherwise test
--    if test -z "${LZ4_LIBS}"; then
+-    # Double check we have a few needed functions
+-    if test "${have_lz4}" = "yes" ; then
 -      AC_CHECK_LIB([lz4],
--                   [LZ4_compress],
--                   [LZ4_LIBS="-llz4"],
+-                   [LZ4_compress_default],
+-                   [],
+-                   [have_lz4="no"])
+-      AC_CHECK_LIB([lz4],
+-                   [LZ4_decompress_safe],
+-                   [],
 -                   [have_lz4="no"])
 -    fi
 -
 -    if test "${have_lz4}" != "yes" ; then
--      AC_MSG_RESULT([         usuable LZ4 library or header not found, using version in src/compat/compat-lz4.*])
+-      AC_MSG_RESULT([         usable LZ4 library or header not found, using version in src/compat/compat-lz4.*])
 -      AC_DEFINE([NEED_COMPAT_LZ4], [1], [use copy of LZ4 source in compat/])
 -      LZ4_LIBS=""
 -    fi
-+    AC_MSG_RESULT([           usuable LZ4 library or header not found, using version in src/compat/compat-lz4.*])
++    AC_MSG_RESULT([           usable LZ4 library or header not found, using version in src/compat/compat-lz4.*])
 +    AC_DEFINE([NEED_COMPAT_LZ4], [1], [use copy of LZ4 source in compat/])
 +    LZ4_LIBS=""
      OPTIONAL_LZ4_CFLAGS="${LZ4_CFLAGS}"