ppp: honor LDFLAGS
[openwrt/openwrt.git] / package / network / services / ppp / patches / 140-pppoe_compile_fix.patch
index 6f24c2cb32620358ee06ac9a3f857f3825e8f6e0..2983a75c42270753efc5f7c0be5dd9f476ff205c 100644 (file)
@@ -1,16 +1,17 @@
 --- a/pppd/plugins/rp-pppoe/plugin.c
 +++ b/pppd/plugins/rp-pppoe/plugin.c
 --- a/pppd/plugins/rp-pppoe/plugin.c
 +++ b/pppd/plugins/rp-pppoe/plugin.c
-@@ -46,9 +46,9 @@ static char const RCSID[] =
+@@ -46,10 +46,10 @@ static char const RCSID[] =
  #include <unistd.h>
  #include <fcntl.h>
  #include <signal.h>
 -#include <net/ethernet.h>
  #include <net/if_arp.h>
  #include <linux/ppp_defs.h>
  #include <unistd.h>
  #include <fcntl.h>
  #include <signal.h>
 -#include <net/ethernet.h>
  #include <net/if_arp.h>
  #include <linux/ppp_defs.h>
-+#include <linux/if_ether.h>
- #include <linux/if_ppp.h>
  #include <linux/if_pppox.h>
  #include <linux/if_pppox.h>
++#include <linux/if_ether.h>
  
  
+ #ifndef _ROOT_PATH
+ #define _ROOT_PATH ""
 --- a/pppd/plugins/rp-pppoe/pppoe.h
 +++ b/pppd/plugins/rp-pppoe/pppoe.h
 @@ -86,17 +86,6 @@ typedef unsigned long UINT32_t;
 --- a/pppd/plugins/rp-pppoe/pppoe.h
 +++ b/pppd/plugins/rp-pppoe/pppoe.h
 @@ -86,17 +86,6 @@ typedef unsigned long UINT32_t;
@@ -90,7 +91,7 @@
 --- a/pppd/plugins/rp-pppoe/Makefile.linux
 +++ b/pppd/plugins/rp-pppoe/Makefile.linux
 @@ -33,7 +33,7 @@ pppoe-discovery: pppoe-discovery.o debug
 --- a/pppd/plugins/rp-pppoe/Makefile.linux
 +++ b/pppd/plugins/rp-pppoe/Makefile.linux
 @@ -33,7 +33,7 @@ pppoe-discovery: pppoe-discovery.o debug
-       $(CC) -o pppoe-discovery pppoe-discovery.o debug.o
+       $(CC) $(CFLAGS) -o pppoe-discovery pppoe-discovery.o debug.o
  
  pppoe-discovery.o: pppoe-discovery.c
 -      $(CC) $(CFLAGS) -c -o pppoe-discovery.o pppoe-discovery.c
  
  pppoe-discovery.o: pppoe-discovery.c
 -      $(CC) $(CFLAGS) -c -o pppoe-discovery.o pppoe-discovery.c