samba36-net: new package
[openwrt/openwrt.git] / package / network / services / samba36 / Makefile
index 7f171ff3aab9741575e5ab74013f06749fd1cc6e..0762dd93071538831e2697a89d46460d7ea701aa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.24
-PKG_RELEASE:=1
+PKG_VERSION:=3.6.25
+PKG_RELEASE:=7
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/stable
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=d98425c0c2b73e08f048d31ffc727fb0
+PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
-PKG_LICENSE:=GPLv3
+PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_BUILD_PARALLEL:=1
 
@@ -34,15 +34,23 @@ define Package/samba36-server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
-  DEPENDS:=+USE_EGLIBC:librt
+  URL:=https://www.samba.org/
+  DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
 define Package/samba36-client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
+  DEPENDS:=+libreadline +libncurses
+endef
+
+define Package/samba36-net
+  SECTION:=net
+  CATEGORY:=Network
+  TITLE:=Samba 3.6 SMB/CIFS net commands
+  URL:=https://www.samba.org/
   DEPENDS:=+libreadline +libncurses
 endef
 
@@ -51,7 +59,6 @@ define Package/samba36-server/config
                int "Maximum level of compiled-in debug messages"
                depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
-
 endef
 
 define Package/samba36-server/description
@@ -82,8 +89,11 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
        samba_cv_have_setresuid=yes \
+       ac_cv_header_libunwind_h=no \
        ac_cv_header_zlib_h=no \
-       samba_cv_zlib_1_2_3=no
+       samba_cv_zlib_1_2_3=no \
+       ac_cv_path_PYTHON="" \
+       ac_cv_path_PYTHON_CONFIG=""
 
 CONFIGURE_ARGS += \
        --exec-prefix=/usr \
@@ -95,6 +105,7 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-swat \
        --disable-shared-libs \
+       --with-libiconv="$(ICONV_PREFIX)" \
        --with-codepagedir=/etc/samba \
        --with-configdir=/etc/samba \
        --with-included-iniparser \
@@ -123,9 +134,15 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+/etc/samba/smb.conf.template
+/etc/samba/smbpasswd
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
+       $(INSTALL_CONF) ./files/samba.config $(1)/etc/config/samba
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
@@ -135,9 +152,9 @@ define Package/samba36-server/install
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
-       ln -sf samba_multicall $(1)/usr/sbin/smbd
-       ln -sf samba_multicall $(1)/usr/sbin/nmbd
-       ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+       $(LN) samba_multicall $(1)/usr/sbin/smbd
+       $(LN) samba_multicall $(1)/usr/sbin/nmbd
+       $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
 define Package/samba36-client/install
@@ -146,6 +163,12 @@ define Package/samba36-client/install
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/nmblookup $(1)/usr/sbin
 endef
 
+define Package/samba36-net/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/net $(1)/usr/sbin
+endef
+
 $(eval $(call BuildPackage,samba36-client))
 $(eval $(call BuildPackage,samba36-server))
+$(eval $(call BuildPackage,samba36-net))