samba36: fix build (issue #5574)
[openwrt/openwrt.git] / package / network / services / samba36 / Makefile
index 9330050e10878a5c6ecd08f07d15c82d86b05a57..55e1428d49e1efa305a7085e86cc9ee89300603b 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,15 +8,19 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.5
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.25
+PKG_RELEASE:=9
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/old-versions
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=2f0c14547333c1b48fd4728b031e7040
+PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_LICENSE:=GPL-3.0
+PKG_LICENSE_FILES:=COPYING
+PKG_CPE_ID:=cpe:/a:samba:samba
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -25,28 +29,37 @@ CONFIGURE_PATH:=source3
 
 PKG_BUILD_BIN:=$(PKG_BUILD_DIR)/$(MAKE_PATH)/bin
 
-define Package/samba36-server
+define Package/samba/Default
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
-  DEPENDS:=+USE_EGLIBC:librt
+  TITLE:=Samba 3.6 SMB/CIFS
+  URL:=https://www.samba.org/
+  MAINTAINER:=Felix Fietkau <nbd@nbd.name>
+endef
+
+define Package/samba36-server
+  $(call Package/samba/Default)
+  TITLE+= server
+  DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
 define Package/samba36-client
-  SECTION:=net
-  CATEGORY:=Network
-  TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  $(call Package/samba/Default)
+  TITLE+= client
+  DEPENDS:=+libreadline +libncurses
+endef
+
+define Package/samba36-net
+  $(call Package/samba/Default)
+  TITLE+= net commands
   DEPENDS:=+libreadline +libncurses
 endef
 
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
-               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
-
 endef
 
 define Package/samba36-server/description
@@ -60,6 +73,8 @@ TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=$(CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL) -D__l
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
+       ac_cv_lib_attr_getxattr=no \
+       ac_cv_search_getxattr=no \
        ac_cv_file__proc_sys_kernel_core_pattern=yes \
        libreplace_cv_HAVE_C99_VSNPRINTF=yes \
        libreplace_cv_HAVE_GETADDRINFO=yes \
@@ -75,19 +90,24 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
        samba_cv_have_setresuid=yes \
+       ac_cv_header_libunwind_h=no \
        ac_cv_header_zlib_h=no \
-       samba_cv_zlib_1_2_3=no
+       samba_cv_zlib_1_2_3=no \
+       ac_cv_path_PYTHON="" \
+       ac_cv_path_PYTHON_CONFIG=""
 
 CONFIGURE_ARGS += \
        --exec-prefix=/usr \
        --prefix=/ \
        --disable-avahi \
        --disable-cups \
+       --disable-external-libtalloc \
        --disable-pie \
        --disable-relro \
        --disable-static \
        --disable-swat \
        --disable-shared-libs \
+       --with-libiconv="$(ICONV_PREFIX)" \
        --with-codepagedir=/etc/samba \
        --with-configdir=/etc/samba \
        --with-included-iniparser \
@@ -98,6 +118,7 @@ CONFIGURE_ARGS += \
        --with-piddir=/var/run \
        --with-privatedir=/etc/samba \
        --with-sendfile-support \
+       --without-acl-support \
        --without-cluster-support \
        --without-ads \
        --without-krb5 \
@@ -109,14 +130,21 @@ CONFIGURE_ARGS += \
        --without-libnetapi \
        --without-libsmbclient \
        --without-libsmbsharemodes \
+       --without-libtevent \
        --without-libaddns \
        --with-shared-modules=pdb_tdbsam,pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+/etc/samba/smb.conf.template
+/etc/samba/smbpasswd
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
+       $(INSTALL_CONF) ./files/samba.config $(1)/etc/config/samba
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
@@ -126,9 +154,9 @@ define Package/samba36-server/install
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
-       ln -sf samba_multicall $(1)/usr/sbin/smbd
-       ln -sf samba_multicall $(1)/usr/sbin/nmbd
-       ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+       $(LN) samba_multicall $(1)/usr/sbin/smbd
+       $(LN) samba_multicall $(1)/usr/sbin/nmbd
+       $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
 define Package/samba36-client/install
@@ -137,6 +165,12 @@ define Package/samba36-client/install
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/nmblookup $(1)/usr/sbin
 endef
 
+define Package/samba36-net/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_BIN)/net $(1)/usr/sbin
+endef
+
 $(eval $(call BuildPackage,samba36-client))
 $(eval $(call BuildPackage,samba36-server))
+$(eval $(call BuildPackage,samba36-net))