ccache, samba36: fix samba.org addresses to use https
[openwrt/openwrt.git] / package / network / services / samba36 / Makefile
index 2842c982bf547e6420e413ca6791943497fa4419..fcf772195ac369c12622d33b674ad3292bd6f887 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2007-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
-PKG_VERSION:=3.6.11
-PKG_RELEASE:=2
+PKG_VERSION:=3.6.25
+PKG_RELEASE:=5
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/old-versions
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=9039e0ab3e4fc632ff0a1a8f2433edb4
+PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
-PKG_LICENSE:=GPLv3
+PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_BUILD_PARALLEL:=1
 
@@ -34,22 +34,22 @@ define Package/samba36-server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
-  DEPENDS:=+USE_EGLIBC:librt
+  URL:=https://www.samba.org/
+  DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
 define Package/samba36-client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+libreadline +libncurses
 endef
 
 define Package/samba36-server/config
        config PACKAGE_SAMBA_MAX_DEBUG_LEVEL
                int "Maximum level of compiled-in debug messages"
-               depends PACKAGE_samba36-server || PACKAGE_samba36-client
+               depends on PACKAGE_samba36-server || PACKAGE_samba36-client
                default -1
 
 endef
@@ -65,6 +65,8 @@ TARGET_CFLAGS += -DMAX_DEBUG_LEVEL=$(CONFIG_PACKAGE_SAMBA_MAX_DEBUG_LEVEL) -D__l
 TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_VARS += \
+       ac_cv_lib_attr_getxattr=no \
+       ac_cv_search_getxattr=no \
        ac_cv_file__proc_sys_kernel_core_pattern=yes \
        libreplace_cv_HAVE_C99_VSNPRINTF=yes \
        libreplace_cv_HAVE_GETADDRINFO=yes \
@@ -80,8 +82,11 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
        samba_cv_have_setresuid=yes \
+       ac_cv_header_libunwind_h=no \
        ac_cv_header_zlib_h=no \
-       samba_cv_zlib_1_2_3=no
+       samba_cv_zlib_1_2_3=no \
+       ac_cv_path_PYTHON="" \
+       ac_cv_path_PYTHON_CONFIG=""
 
 CONFIGURE_ARGS += \
        --exec-prefix=/usr \
@@ -93,6 +98,7 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-swat \
        --disable-shared-libs \
+       --with-libiconv="$(ICONV_PREFIX)" \
        --with-codepagedir=/etc/samba \
        --with-configdir=/etc/samba \
        --with-included-iniparser \
@@ -103,6 +109,7 @@ CONFIGURE_ARGS += \
        --with-piddir=/var/run \
        --with-privatedir=/etc/samba \
        --with-sendfile-support \
+       --without-acl-support \
        --without-cluster-support \
        --without-ads \
        --without-krb5 \
@@ -114,14 +121,21 @@ CONFIGURE_ARGS += \
        --without-libnetapi \
        --without-libsmbclient \
        --without-libsmbsharemodes \
+       --without-libtevent \
        --without-libaddns \
        --with-shared-modules=pdb_tdbsam,pdb_wbc_sam,idmap_nss,nss_info_template,auth_winbind,auth_wbc,auth_domain
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+/etc/samba/smb.conf.template
+/etc/samba/smbpasswd
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
+       $(INSTALL_CONF) ./files/samba.config $(1)/etc/config/samba
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
@@ -131,9 +145,9 @@ define Package/samba36-server/install
        $(INSTALL_BIN) ./files/samba.init $(1)/etc/init.d/samba
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_BIN)/samba_multicall $(1)/usr/sbin
-       ln -sf samba_multicall $(1)/usr/sbin/smbd
-       ln -sf samba_multicall $(1)/usr/sbin/nmbd
-       ln -sf samba_multicall $(1)/usr/sbin/smbpasswd
+       $(LN) samba_multicall $(1)/usr/sbin/smbd
+       $(LN) samba_multicall $(1)/usr/sbin/nmbd
+       $(LN) samba_multicall $(1)/usr/sbin/smbpasswd
 endef
 
 define Package/samba36-client/install