ccache, samba36: fix samba.org addresses to use https
[openwrt/openwrt.git] / package / network / services / samba36 / Makefile
index 70dfb2b16f6ff796a7483def5c27e8e0e2d871f8..fcf772195ac369c12622d33b674ad3292bd6f887 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.25
-PKG_RELEASE:=1
+PKG_RELEASE:=5
 
-PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
-       http://ftp.samba.org/pub/samba/stable
+PKG_SOURCE_URL:=https://download.samba.org/pub/samba \
+               https://download.samba.org/pub/samba/stable
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=76da2fa64edd94a0188531e7ecb27c4e
+PKG_HASH:=8f2c8a7f2bd89b0dfd228ed917815852f7c625b2bc0936304ac3ed63aaf83751
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
 
-PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
 
 PKG_BUILD_PARALLEL:=1
 
@@ -34,15 +34,15 @@ define Package/samba36-server
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS server
-  URL:=http://www.samba.org/
-  DEPENDS:=+USE_GLIBC:librt
+  URL:=https://www.samba.org/
+  DEPENDS:=+USE_GLIBC:librt $(ICONV_DEPENDS)
 endef
 
 define Package/samba36-client
   SECTION:=net
   CATEGORY:=Network
   TITLE:=Samba 3.6 SMB/CIFS client
-  URL:=http://www.samba.org/
+  URL:=https://www.samba.org/
   DEPENDS:=+libreadline +libncurses
 endef
 
@@ -82,8 +82,11 @@ CONFIGURE_VARS += \
        samba_cv_USE_SETRESUID=yes \
        samba_cv_have_setreuid=yes \
        samba_cv_have_setresuid=yes \
+       ac_cv_header_libunwind_h=no \
        ac_cv_header_zlib_h=no \
-       samba_cv_zlib_1_2_3=no
+       samba_cv_zlib_1_2_3=no \
+       ac_cv_path_PYTHON="" \
+       ac_cv_path_PYTHON_CONFIG=""
 
 CONFIGURE_ARGS += \
        --exec-prefix=/usr \
@@ -95,6 +98,7 @@ CONFIGURE_ARGS += \
        --disable-static \
        --disable-swat \
        --disable-shared-libs \
+       --with-libiconv="$(ICONV_PREFIX)" \
        --with-codepagedir=/etc/samba \
        --with-configdir=/etc/samba \
        --with-included-iniparser \
@@ -123,9 +127,15 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+/etc/samba/smb.conf.template
+/etc/samba/smbpasswd
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
+       $(INSTALL_CONF) ./files/samba.config $(1)/etc/config/samba
        $(INSTALL_DIR) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba