uhttpd: use configured distribution name for SSL certificate CN
[openwrt/openwrt.git] / package / network / services / uhttpd / Makefile
index e6e6753a688607b515aa4a040da23d66ef9c8ed5..ab5ef64bb560cbcd1779203b08a116446eda8a84 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2010-2014 Jo-Philipp Wich <jow@openwrt.org>
+# Copyright (C) 2010-2015 Jo-Philipp Wich <jow@openwrt.org>
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2014-10-27
+PKG_VERSION:=2015-11-08
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
+PKG_SOURCE_URL=$(OPENWRT_GIT)/project/uhttpd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=fd8e5e379c23c5fbcec3e76894b839233df09067
+PKG_SOURCE_VERSION:=fe01ef3f52adae9da38ef47926cd50974af5d6b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 PKG_LICENSE:=ISC
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 PKG_LICENSE:=ISC
@@ -23,6 +23,7 @@ PKG_BUILD_DEPENDS = ustream-ssl
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
+include $(INCLUDE_DIR)/version.mk
 
 define Package/uhttpd/default
   SECTION:=net
 
 define Package/uhttpd/default
   SECTION:=net
@@ -33,7 +34,7 @@ endef
 
 define Package/uhttpd
   $(Package/uhttpd/default)
 
 define Package/uhttpd
   $(Package/uhttpd/default)
-  DEPENDS:=+libubox
+  DEPENDS:=+libubox +libblobmsg-json +libjson-script
 endef
 
 define Package/uhttpd/description
 endef
 
 define Package/uhttpd/description
@@ -54,6 +55,7 @@ define Package/uhttpd-mod-tls
   TITLE+= (TLS plugin)
   DEPENDS:=uhttpd \
        +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
   TITLE+= (TLS plugin)
   DEPENDS:=uhttpd \
        +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+       +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
        +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
        +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
        +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
        +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
@@ -68,6 +70,9 @@ define Package/uhttpd-mod-tls/config
     prompt "TLS Provider"
     default PACKAGE_uhttpd-mod-tls_polarssl
 
     prompt "TLS Provider"
     default PACKAGE_uhttpd-mod-tls_polarssl
 
+    config PACKAGE_uhttpd-mod-tls_mbedtls
+      bool "mbedTLS"
+
     config PACKAGE_uhttpd-mod-tls_polarssl
       bool "PolarSSL"
 
     config PACKAGE_uhttpd-mod-tls_polarssl
       bool "PolarSSL"
 
@@ -107,6 +112,10 @@ define Package/uhttpd/conffiles
 /etc/uhttpd.key
 endef
 
 /etc/uhttpd.key
 endef
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on
@@ -116,6 +125,7 @@ define Package/uhttpd/install
        $(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
        $(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
+       $(VERSION_SED_SCRIPT) $(1)/etc/config/uhttpd
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
 endef
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
 endef