uhttpd: add option for mbedtls
[openwrt/openwrt.git] / package / network / services / uhttpd / Makefile
index d14e3a942ec1c567bf1e1c90a00c17b9eb9d5878..da5572b5fe5907192f73fa4271460234657784a3 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_VERSION:=2015-10-20
+PKG_VERSION:=2015-11-08
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=git://nbd.name/uhttpd2.git
+PKG_SOURCE_URL=$(OPENWRT_GIT)/project/uhttpd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=618315bc0729c3064e06af2900a86211354f81c9
+PKG_SOURCE_VERSION:=fe01ef3f52adae9da38ef47926cd50974af5d6b7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 PKG_LICENSE:=ISC
@@ -33,7 +33,7 @@ endef
 
 define Package/uhttpd
   $(Package/uhttpd/default)
-  DEPENDS:=+libubox
+  DEPENDS:=+libubox +libblobmsg-json +libjson-script
 endef
 
 define Package/uhttpd/description
@@ -54,6 +54,7 @@ define Package/uhttpd-mod-tls
   TITLE+= (TLS plugin)
   DEPENDS:=uhttpd \
        +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+       +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
        +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
        +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
@@ -68,6 +69,9 @@ define Package/uhttpd-mod-tls/config
     prompt "TLS Provider"
     default PACKAGE_uhttpd-mod-tls_polarssl
 
+    config PACKAGE_uhttpd-mod-tls_mbedtls
+      bool "mbedTLS"
+
     config PACKAGE_uhttpd-mod-tls_polarssl
       bool "PolarSSL"