packages: more (e)glibc fixes after r44701
[openwrt/openwrt.git] / package / network / services / uhttpd / Makefile
index 7c0989de1a520437fa402f70f826781e7ca18702..f4de987e659700db3c2f6d77f8b65a1a53305b6b 100644 (file)
@@ -107,6 +107,10 @@ define Package/uhttpd/conffiles
 /etc/uhttpd.key
 endef
 
+ifneq ($(CONFIG_USE_GLIBC),)
+  TARGET_CFLAGS += -D_DEFAULT_SOURCE
+endif
+
 TARGET_LDFLAGS += -lcrypt
 
 CMAKE_OPTIONS = -DTLS_SUPPORT=on