curl: update to version 7.51.0
[openwrt/openwrt.git] / package / network / utils / curl / Makefile
index a77fcc89a7d6262870e979e1f00cc1ef1a78e0fd..d1e80976026dee76ebbf60726db1e5609f312032 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2014 OpenWrt.org
+# Copyright (C) 2007-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=curl
-PKG_VERSION:=7.38.0
+PKG_VERSION:=7.51.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -18,7 +18,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
        ftp://ftp.planetmirror.com/pub/curl/ \
        http://www.mirrormonster.com/curl/download/ \
        http://curl.mirrors.cyberservers.net/download/
-PKG_MD5SUM:=af6b3c299bd891f43cb5f76c4091b7b4
+PKG_MD5SUM:=7f8240048907e5030f67be0a6129bc4b333783b9cca1391026d700835a788dde
 
 PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=COPYING
@@ -26,34 +26,46 @@ PKG_LICENSE_FILES:=COPYING
 PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
 
-PKG_CONFIG_DEPENDS := \
-  LIBCURL_AXTLS \
-  LIBCURL_COOKIES \
-  LIBCURL_CRYPTO_AUTH \
-  LIBCURL_CYASSL \
-  LIBCURL_DICT \
-  LIBCURL_FILE \
-  LIBCURL_FTP \
-  LIBCURL_GNUTLS \
-  LIBCURL_GOPHER \
-  LIBCURL_HTTP \
-  LIBCURL_IMAP \
-  LIBCURL_LDAP \
-  LIBCURL_LDAPS \
-  LIBCURL_LIBCURL_OPTION \
-  LIBCURL_NOSSL \
-  LIBCURL_OPENSSL \
-  LIBCURL_POLARSSL \
-  LIBCURL_POP3 \
-  LIBCURL_PROXY \
-  LIBCURL_RTSP \
-  LIBCURL_SMTP \
-  LIBCURL_SSPI \
-  LIBCURL_TELNET \
-  LIBCURL_TFTP \
-  LIBCURL_THREADED_RESOLVER \
-  LIBCURL_TLS-SRP \
-  LIBCURL_ZLIB
+PKG_CONFIG_DEPENDS:= \
+  CONFIG_IPV6 \
+  \
+  CONFIG_LIBCURL_CYASSL \
+  CONFIG_LIBCURL_GNUTLS \
+  CONFIG_LIBCURL_OPENSSL \
+  CONFIG_LIBCURL_POLARSSL \
+  CONFIG_LIBCURL_MBEDTLS \
+  CONFIG_LIBCURL_NOSSL \
+  \
+  CONFIG_LIBCURL_LIBIDN \
+  CONFIG_LIBCURL_SSH2 \
+  CONFIG_LIBCURL_ZLIB \
+  \
+  CONFIG_LIBCURL_DICT \
+  CONFIG_LIBCURL_FILE \
+  CONFIG_LIBCURL_FTP \
+  CONFIG_LIBCURL_GOPHER \
+  CONFIG_LIBCURL_HTTP \
+  CONFIG_LIBCURL_IMAP \
+  CONFIG_LIBCURL_LDAP \
+  CONFIG_LIBCURL_LDAPS \
+  CONFIG_LIBCURL_POP3 \
+  CONFIG_LIBCURL_RTSP \
+  CONFIG_LIBCURL_NO_RTSP \
+  CONFIG_LIBCURL_SMB \
+  CONFIG_LIBCURL_NO_SMB \
+  CONFIG_LIBCURL_SMTP \
+  CONFIG_LIBCURL_TELNET \
+  CONFIG_LIBCURL_TFTP \
+  \
+  CONFIG_LIBCURL_COOKIES \
+  CONFIG_LIBCURL_CRYPTO_AUTH \
+  CONFIG_LIBCURL_LIBCURL_OPTION \
+  CONFIG_LIBCURL_PROXY \
+  CONFIG_LIBCURL_THREADED_RESOLVER \
+  CONFIG_LIBCURL_TLS_SRP \
+  CONFIG_LIBCURL_UNIX_SOCKETS \
+  CONFIG_LIBCURL_VERBOSE \
+  CONFIG_LIBCURL_NTLM
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -75,8 +87,9 @@ define Package/libcurl
   $(call Package/curl/Default)
   SECTION:=libs
   CATEGORY:=Libraries
-  DEPENDS:=+LIBCURL_POLARSSL:libpolarssl +LIBCURL_CYASSL:libcyassl +LIBCURL_AXTLS:libaxtls +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread
-  TITLE:=A client-side URL transfer library using $(if $(CONFIG_LIBCURL_POLARSSL),PolarSSL)$(if $(CONFIG_LIBCURL_OPENSSL),OpenSSL)$(if $(CONFIG_LIBCURL_GNUTLS),GNUTLS)$(if $(CONFIG_LIBCURL_NOSSL),no SSL)
+  DEPENDS:=+LIBCURL_POLARSSL:libpolarssl +LIBCURL_CYASSL:libcyassl +LIBCURL_OPENSSL:libopenssl +LIBCURL_GNUTLS:libgnutls +LIBCURL_MBEDTLS:libmbedtls
+  DEPENDS += +LIBCURL_ZLIB:zlib +LIBCURL_THREADED_RESOLVER:libpthread +LIBCURL_LDAP:libopenldap +LIBCURL_LIBIDN:libidn +LIBCURL_SSH2:libssh2
+  TITLE:=A client-side URL transfer library
   MENU:=1
 endef
 
@@ -85,50 +98,55 @@ define Package/libcurl/config
   source "$(SOURCE)/Config.in"
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections
+TARGET_CPPFLAGS += $(if $(CONFIG_LIBCURL_NTLM),,-DCURL_DISABLE_NTLM)
+TARGET_LDFLAGS += -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
+       --disable-debug \
+       --disable-ares \
        --enable-shared \
        --enable-static \
-       --disable-thread \
-       --enable-nonblocking \
-       --disable-ares \
-       --disable-debug \
        --disable-manual \
-       --disable-verbose \
-       --without-ca-bundle \
-       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ca-path=/etc/ssl/certs/) \
-       --without-krb4 \
-       --without-libidn \
        --without-nss \
-       --without-libssh2 \
+       --without-libmetalink \
+       --without-librtmp \
+       \
        $(call autoconf_bool,CONFIG_IPV6,ipv6) \
-       $(if $(CONFIG_LIBCURL_AXTLS),--with-axtls="$(STAGING_DIR)/usr",--without-axtls) \
-       $(if $(CONFIG_LIBCURL_COOKIES),--enable,--disable)-cookies \
-       $(if $(CONFIG_LIBCURL_CRYPTO-AUTH),--enable,--disable)-crypto-auth \
-       $(if $(CONFIG_LIBCURL_CYASSL),--with-cyassl="$(STAGING_DIR)/usr",--without-cyassl) \
-       $(if $(CONFIG_LIBCURL_DICT),--enable,--disable)-dict \
-       $(if $(CONFIG_LIBCURL_FILE),--enable,--disable)-file \
-       $(if $(CONFIG_LIBCURL_FTP),--enable,--disable)-ftp \
-       $(if $(CONFIG_LIBCURL_GOPHER),--enable,--disable)-gopher \
-       $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
-       $(if $(CONFIG_LIBCURL_HTTP),--enable,--disable)-http \
-       $(if $(CONFIG_LIBCURL_IMAP),--enable,--disable)-imap \
-       $(if $(CONFIG_LIBCURL_LDAP),--enable,--disable)-ldap \
-       $(if $(CONFIG_LIBCURL_LDAPS),--enable,--disable)-ldaps \
-       $(if $(CONFIG_LIBCURL_LIBCURL-OPTION),--enable,--disable)-libcurl-option \
-       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ssl="$(STAGING_DIR)/usr",--without-ssl) \
-       $(if $(CONFIG_LIBCURL_POLARSSL),--with-polarssl="$(STAGING_DIR)/usr",--without-polarssl) \
-       $(if $(CONFIG_LIBCURL_POP3),--enable,--disable)-pop3 \
-       $(if $(CONFIG_LIBCURL_PROXY),--enable,--disable)-proxy \
-       $(if $(CONFIG_LIBCURL_RTSP),--enable,--disable)-rtsp \
-       $(if $(CONFIG_LIBCURL_TELNET),--enable,--disable)-telnet \
-       $(if $(CONFIG_LIBCURL_TFTP),--enable,--disable)-tftp \
-       $(if $(CONFIG_LIBCURL_SMTP),--enable,--disable)-smtp \
-       $(if $(CONFIG_LIBCURL_SSPI),--enable,--disable)-sspi \
-       $(if $(CONFIG_LIBCURL_THREADED_RESOLVER),--enable,--disable)-threaded-resolver \
-       $(if $(CONFIG_LIBCURL_TLS-SRP),--enable,--disable)-tls-srp \
+       \
+       $(if $(CONFIG_LIBCURL_CYASSL),--with-cyassl="$(STAGING_DIR)/usr" --without-ca-path --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt,--without-cyassl) \
+       $(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-gnutls) \
+       $(if $(CONFIG_LIBCURL_OPENSSL),--with-ssl="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-ssl) \
+       $(if $(CONFIG_LIBCURL_POLARSSL),--with-polarssl="$(STAGING_DIR)/usr" --without-ca-bundle --with-ca-path=/etc/ssl/certs,--without-polarssl) \
+       $(if $(CONFIG_LIBCURL_MBEDTLS),--with-mbedtls="$(STAGING_DIR)/usr" --without-ca-path --with-ca-bundle=/etc/ssl/certs/ca-certificates.crt,--without-mbedtls) \
+       \
+       $(if $(CONFIG_LIBCURL_LIBIDN),--with-libidn="$(STAGING_DIR)/usr",--without-libidn) \
+       $(if $(CONFIG_LIBCURL_SSH2),--with-libssh2="$(STAGING_DIR)/usr",--without-libssh2) \
        $(if $(CONFIG_LIBCURL_ZLIB),--with-zlib="$(STAGING_DIR)/usr",--without-zlib) \
+       \
+       $(call autoconf_bool,CONFIG_LIBCURL_DICT,dict) \
+       $(call autoconf_bool,CONFIG_LIBCURL_FILE,file) \
+       $(call autoconf_bool,CONFIG_LIBCURL_FTP,ftp) \
+       $(call autoconf_bool,CONFIG_LIBCURL_GOPHER,gopher) \
+       $(call autoconf_bool,CONFIG_LIBCURL_HTTP,http) \
+       $(call autoconf_bool,CONFIG_LIBCURL_IMAP,imap) \
+       $(call autoconf_bool,CONFIG_LIBCURL_LDAP,ldap) \
+       $(call autoconf_bool,CONFIG_LIBCURL_LDAPS,ldaps) \
+       $(call autoconf_bool,CONFIG_LIBCURL_POP3,pop3) \
+       $(call autoconf_bool,CONFIG_LIBCURL_RTSP,rtsp) \
+       $(call autoconf_bool,CONFIG_LIBCURL_SMB,smb) \
+       $(call autoconf_bool,CONFIG_LIBCURL_SMTP,smtp) \
+       $(call autoconf_bool,CONFIG_LIBCURL_TELNET,telnet) \
+       $(call autoconf_bool,CONFIG_LIBCURL_TFTP,tftp) \
+       \
+       $(call autoconf_bool,CONFIG_LIBCURL_COOKIES,cookies) \
+       $(call autoconf_bool,CONFIG_LIBCURL_CRYPTO_AUTH,crypto-auth) \
+       $(call autoconf_bool,CONFIG_LIBCURL_LIBCURL_OPTION,libcurl-option) \
+       $(call autoconf_bool,CONFIG_LIBCURL_PROXY,proxy) \
+       $(call autoconf_bool,CONFIG_LIBCURL_THREADED_RESOLVER,threaded-resolver) \
+       $(call autoconf_bool,CONFIG_LIBCURL_TLS_SRP,tls-srp) \
+       $(call autoconf_bool,CONFIG_LIBCURL_UNIX_SOCKETS,unix-sockets) \
+       $(call autoconf_bool,CONFIG_LIBCURL_VERBOSE,verbose) \
 
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
@@ -145,7 +163,7 @@ define Build/InstallDev
        $(CP) $(PKG_BUILD_DIR)/libcurl.pc $(1)/usr/lib/pkgconfig/
        $(SED) 's,-L$$$${exec_prefix}/lib,,g' $(1)/usr/bin/curl-config
        [ -n "$(TARGET_LDFLAGS)" ] && $(SED) 's#$(TARGET_LDFLAGS)##g' $(1)/usr/lib/pkgconfig/libcurl.pc || true
-       ln -sf $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
+       $(LN) $(STAGING_DIR)/usr/bin/curl-config $(2)/bin/
 endef
 
 define Package/curl/install