iproute2: update to 4.16
[openwrt/openwrt.git] / package / network / utils / iproute2 / patches / 300-ip_tiny.patch
index d48ea8581c78b5df111f1b2bac9805e5617b4d9b..d8f39d39107ae5165585ffa1c9e3da587bdf239e 100644 (file)
@@ -1,8 +1,8 @@
 --- a/ip/Makefile
 +++ b/ip/Makefile
-@@ -28,6 +28,13 @@ ifeq ($(HAVE_MNL),y)
-       LDLIBS += $(shell $(PKG_CONFIG) libmnl --libs)
- endif
+@@ -16,6 +16,13 @@ RTMONOBJ=rtmon.o
+ include ../config.mk
  
 +STATIC_SYM_FILTER:=
 +ifeq ($(IP_CONFIG_TINY),y)
@@ -14,7 +14,7 @@
  ALLOBJ=$(IPOBJ) $(RTMONOBJ)
  SCRIPTS=ifcfg rtpr routel routef
  TARGETS=ip rtmon
-@@ -57,7 +64,7 @@ else
+@@ -45,7 +52,7 @@ else
  
  ip: static-syms.o
  static-syms.o: static-syms.h
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
 --- a/ip/ip.c
 +++ b/ip/ip.c
-@@ -74,32 +74,44 @@ static const struct cmd {
+@@ -48,10 +48,16 @@ static void usage(void)
+       fprintf(stderr,
+ "Usage: ip [ OPTIONS ] OBJECT { COMMAND | help }\n"
+ "       ip [ -force ] -batch filename\n"
++#ifndef IPROUTE2_TINY
+ "where  OBJECT := { link | address | addrlabel | route | rule | neigh | ntable |\n"
+ "                   tunnel | tuntap | maddress | mroute | mrule | monitor | xfrm |\n"
+ "                   netns | l2tp | fou | macsec | tcp_metrics | token | netconf | ila |\n"
+ "                   vrf | sr }\n"
++#else
++"where  OBJECT := { link | address | route | rule | neigh | tunnel | maddress |\n"
++"                   mroute | mrule | monitor | netns | macsec | token | ila |\n"
++"                   vrf | sr }\n"
++#endif
+ "       OPTIONS := { -V[ersion] | -s[tatistics] | -d[etails] | -r[esolve] |\n"
+ "                    -h[uman-readable] | -iec |\n"
+ "                    -f[amily] { inet | inet6 | ipx | dnet | mpls | bridge | link } |\n"
+@@ -73,32 +79,44 @@ static const struct cmd {
        int (*func)(int argc, char **argv);
  } cmds[] = {
        { "address",    do_ipaddr },
@@ -72,7 +89,7 @@
        { "help",       do_help },
 --- a/lib/utils.c
 +++ b/lib/utils.c
-@@ -787,6 +787,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -983,6 +983,7 @@ const char *rt_addr_n2a_r(int af, int le
                return inet_ntop(af, addr, buf, buflen);
        case AF_MPLS:
                return mpls_ntop(af, addr, buf, buflen);
        case AF_IPX:
                return ipx_ntop(af, addr, buf, buflen);
        case AF_DECnet:
-@@ -796,6 +797,7 @@ const char *rt_addr_n2a_r(int af, int le
+@@ -992,6 +993,7 @@ const char *rt_addr_n2a_r(int af, int le
                memcpy(dna.a_addr, addr, 2);
                return dnet_ntop(af, &dna, buf, buflen);
        }
 +#endif
        case AF_PACKET:
                return ll_addr_n2a(addr, len, ARPHRD_VOID, buf, buflen);
-       default:
+       case AF_BRIDGE:
 --- a/lib/Makefile
 +++ b/lib/Makefile
-@@ -12,6 +12,10 @@ ifeq ($(HAVE_MNL),y)
-       CFLAGS += -DHAVE_LIBMNL $(shell $(PKG_CONFIG) libmnl --cflags)
- endif
+@@ -3,6 +3,10 @@ include ../config.mk
+ CFLAGS += $(FPIC)
  
 +ifeq ($(IP_CONFIG_TINY),y)
 +  CFLAGS += -DIPROUTE2_TINY
 +endif
 +
- CFLAGS += $(FPIC)
  UTILOBJ = utils.o rt_names.o ll_types.o ll_proto.o ll_addr.o \
+       inet_proto.o namespace.o json_writer.o json_print.o \
+       names.o color.o bpf.o exec.o fs.o