iw: update to version 4.1
[openwrt/openwrt.git] / package / network / utils / iw / patches / 200-reduce_size.patch
index 882cf89f8d4a9a6c7b1ed7a73eeeaa217a6e6208..0204f0b032aafb4cde734332df46822098b37894 100644 (file)
@@ -1,19 +1,17 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -15,8 +15,8 @@ CFLAGS += -Wall -Wundef -Wstrict-prototy
- OBJS = iw.o genl.o event.o info.o phy.o \
-       interface.o ibss.o station.o survey.o util.o \
-       mesh.o mpath.o scan.o reg.o version.o \
--      reason.o status.o connect.o link.o offch.o ps.o cqm.o \
--      bitrate.o wowlan.o coalesce.o roc.o p2p.o
-+      reason.o status.o connect.o link.o ps.o \
-+      bitrate.o
+@@ -16,7 +16,7 @@ OBJS = iw.o genl.o event.o info.o phy.o
+       interface.o ibss.o station.o survey.o util.o ocb.o \
+       mesh.o mpath.o mpp.o scan.o reg.o version.o \
+       reason.o status.o connect.o link.o offch.o ps.o cqm.o \
+-      bitrate.o wowlan.o coalesce.o roc.o p2p.o vendor.o
++      bitrate.o vendor.o
  OBJS += sections.o
  
  OBJS-$(HWSIM) += hwsim.o
 --- a/info.c
 +++ b/info.c
-@@ -207,6 +207,7 @@ next:
+@@ -219,6 +219,7 @@ next:
                                }
                        }
  
@@ -21,7 +19,7 @@
                        if (tb_band[NL80211_BAND_ATTR_RATES]) {
                        printf("\t\tBitrates (non-HT):\n");
                        nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
-@@ -223,6 +224,7 @@ next:
+@@ -235,6 +236,7 @@ next:
                                printf("\n");
                        }
                        }
@@ -29,7 +27,7 @@
                }
        }
  
-@@ -273,6 +275,7 @@ next:
+@@ -291,6 +293,7 @@ next:
                printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
        }
  
@@ -37,7 +35,7 @@
        if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
                int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
                int i;
-@@ -284,6 +287,7 @@ next:
+@@ -302,6 +305,7 @@ next:
                                        cipher_name(ciphers[i]));
                }
        }
@@ -45,7 +43,7 @@
  
        if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
            tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
-@@ -303,11 +307,13 @@ next:
+@@ -321,11 +325,13 @@ next:
                        printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
        }
  
@@ -59,7 +57,7 @@
  
        if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
                struct nlattr *nl_combi;
-@@ -404,6 +410,7 @@ broken_combination:
+@@ -422,6 +428,7 @@ broken_combination:
                        printf("\tinterface combinations are not supported\n");
        }
  
@@ -67,7 +65,7 @@
        if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
                printf("\tSupported commands:\n");
                nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
-@@ -496,6 +503,7 @@ broken_combination:
+@@ -518,6 +525,7 @@ broken_combination:
                                printf("\t\t * wake up on TCP connection\n");
                }
        }
@@ -75,7 +73,7 @@
  
        if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
                printf("\tDevice supports roaming.\n");
-@@ -532,6 +540,7 @@ broken_combination:
+@@ -554,6 +562,7 @@ broken_combination:
                }
        }
  
        if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
                unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
  
-@@ -584,6 +593,7 @@ broken_combination:
-               if (features & NL80211_FEATURE_DYNAMIC_SMPS)
-                       printf("\tDevice supports dynamic SMPS\n");
+@@ -612,6 +621,7 @@ broken_combination:
+               if (features & NL80211_FEATURE_TDLS_CHANNEL_SWITCH)
+                       printf("\tDevice supports TDLS channel switching\n");
        }
 +#endif
  
-       if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
-               printf("\tDevice supports T-DLS.\n");
-@@ -633,6 +643,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
+       if (tb_msg[NL80211_ATTR_EXT_FEATURES]) {
+               struct nlattr *tb = tb_msg[NL80211_ATTR_EXT_FEATURES];
+@@ -669,6 +679,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
         "List all wireless devices and their capabilities.");
  TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
  
@@ -99,7 +97,7 @@
  static int handle_commands(struct nl80211_state *state,
                           struct nl_cb *cb, struct nl_msg *msg,
                           int argc, char **argv, enum id_input id)
-@@ -645,6 +656,7 @@ static int handle_commands(struct nl8021
+@@ -681,6 +692,7 @@ static int handle_commands(struct nl8021
  }
  TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
         "list all known commands and their decimal & hex value");