nftables: update to version 0.8.2
[openwrt/openwrt.git] / package / network / utils / nftables / Makefile
index 4f25ee91e768a694fe5c7db759f5c0dc17fbfc36..182fcace3b7f6bce87c54fb4e4c1d990e1639699 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright (C) 2014 OpenWrt.org
+# Copyright (C) 2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,14 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nftables
-PKG_VERSION:=0.3+2014-10-21
+PKG_VERSION:=0.8.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=git://git.netfilter.org/nftables
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=17b495957b29e699f59874d1ceca9535921b1a79
+PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
+PKG_HASH:=675f0aaf88f11e7eacef63dc89cb65d207d9e09c3ea6d518f0ebbb013f0767ec
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 PKG_LICENSE:=GPL-2.0
 
@@ -22,9 +20,10 @@ PKG_FIXUP:=autoreconf
 
 include $(INCLUDE_DIR)/package.mk
 
+DISABLE_NLS:=
+
 CONFIGURE_ARGS += \
-        --disable-debug \
-        --without-libgmp \
+        --with-mini-gmp \
         --without-cli \
 
 define Package/nftables
@@ -32,7 +31,7 @@ define Package/nftables
   CATEGORY:=Network
   SUBMENU:=Firewall
   TITLE:=nftables packet filtering userspace utility
-  DEPENDS:=+kmod-nft-core +kmod-nft-nat +libnftnl
+  DEPENDS:=+kmod-nft-core +libnftnl
   URL:=http://netfilter.org/projects/nftables/
 endef