replace lots of manual install commands with INSTALL_* variables
[openwrt/openwrt.git] / package / nvram / Makefile
index ab33c115144e963ecc3ae57e1114ac5704262f4a..87e8b0659eaeed14317666a56fc4af5849cbc730 100644 (file)
@@ -40,10 +40,10 @@ define Build/UninstallDev
 endef
 
 define Package/nvram/install
-       install -d -m0755 $(1)/usr/lib
+       $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nvram $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,nvram))