added our own pkg-config wrapper, making the sed foo on *.pc files obselete 1/2
[openwrt/openwrt.git] / package / openssl / Makefile
index 9a9661e7830f40f624c15d29fed1ec733b61dd24..555099bd07a9795ba51fa2247c77ca76e9cb24e4 100644 (file)
@@ -9,38 +9,42 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=openssl
-PKG_VERSION:=0.9.8d
-PKG_RELEASE:=1
+PKG_VERSION:=0.9.8e
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.openssl.org/source/ \
        ftp://ftp.funet.fi/pub/crypt/cryptography/libs/openssl/source/ \
        ftp://ftp.webmonster.de/pub/openssl/source/ \
        ftp://ftp.sunet.se/pub/security/tools/net/openssl/source/
-PKG_MD5SUM:=8ed1853538e1d05a1f5ada61ebf8bffa
+PKG_MD5SUM:=3a7ff24f6ea5cd711984722ad654b927
 
 include $(INCLUDE_DIR)/package.mk
 
 define Package/openssl/Default
   TITLE:=Open source SSL toolkit
-  DESCRIPTION:=\
-       The OpenSSL Project is a collaborative effort to develop a robust, \\\
-       commercial-grade, full-featured, and Open Source toolkit implementing the \\\
-       Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) \\\
-       protocols as well as a full-strength general purpose cryptography library.
   URL:=http://www.openssl.org/
 endef
 
+define Package/openssl/Default/description
+ The OpenSSL Project is a collaborative effort to develop a robust, 
+ commercial-grade, full-featured, and Open Source toolkit implementing the 
+ Secure Sockets Layer (SSL v2/v3) and Transport Layer Security (TLS v1) 
+ protocols as well as a full-strength general purpose cryptography library.
+endef
+
 define Package/libopenssl
-  $(call Package/openssl/Default)
+$(call Package/openssl/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   DEPENDS:=+zlib
   TITLE+= (libraries)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL shared libraries, needed by other \\\
-       programs.
+endef
+
+define Package/libopenssl/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL shared libraries, needed by other 
+ programs.
 endef
 
 define Package/openssl-util
@@ -49,18 +53,21 @@ define Package/openssl-util
   CATEGORY:=Utilities
   DEPENDS:=+libopenssl
   TITLE+= (utility)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the OpenSSL command-line utility.
 endef
 
 define Package/openssl-util/conffiles
 /etc/ssl/openssl.cnf
 endef
 
+define Package/openssl-util/description
+$(call Package/openssl/Default/description)
+ This package contains the OpenSSL command-line utility.
+endef
+
+
 OPENSSL_NO_CIPHERS:= no-idea no-md2 no-mdc2 no-rc2 no-rc5 no-sha0 no-smime \
                                        no-rmd160 no-aes192 no-ripemd no-camellia no-ans1 no-krb5
-OPENSSL_OPTIONS:= shared no-dso no-ec no-err no-fips no-hw no-threads zlib-dynamic \
+OPENSSL_OPTIONS:= shared no-ec no-err no-fips no-hw no-threads zlib-dynamic \
                                        no-engines no-sse2 no-perlasm
 
 
@@ -69,8 +76,8 @@ define Build/Configure
                ./Configure linux-openwrt \
                        --prefix=/usr \
                        --openssldir=/etc/ssl \
-                       -I$(STAGING_DIR)/usr/include \
-                       -L$(STAGING_DIR)/usr/lib -ldl \
+                       $(TARGET_CPPFLAGS) \
+                       $(TARGET_LDFLAGS) -ldl \
                        -DOPENSSL_SMALL_FOOTPRINT \
                        $(OPENSSL_NO_CIPHERS) \
                        $(OPENSSL_OPTIONS) \
@@ -102,15 +109,19 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       mkdir -p $(STAGING_DIR)/usr/include
-       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(STAGING_DIR)/usr/include/
-       mkdir -p $(STAGING_DIR)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(STAGING_DIR)/usr/lib/
+       mkdir -p $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/openssl $(1)/usr/include/
+       mkdir -p $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{crypto,ssl}.{a,so*} $(1)/usr/lib/
+       mkdir -p $(1)/usr/lib/pkgconfig
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc $(1)/usr/lib/pkgconfig/
+       $(SED) 's,$(TARGET_LDFLAGS),,g' $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Build/UninstallDev
-       rm -rf  $(STAGING_DIR)/usr/include/openssl \
-               $(STAGING_DIR)/usr/lib/lib{crypto,ssl}.{a,so*}
+       rm -rf  $(1)/usr/include/openssl \
+               $(1)/usr/lib/lib{crypto,ssl}.{a,so*} \
+               $(1)/usr/lib/pkgconfig/{openssl,libcrypto,libssl}.pc
 endef
 
 define Package/libopenssl/install