opkg: remove manual automake invocations and rely and host and target fixups
[openwrt/openwrt.git] / package / opkg / Makefile
index 2870abdc038af1cef9b5f9aa0662b91d3f7c41c7..4d702bae9cfbe007cd3bb9b36c85ae7bfaa6d5ec 100644 (file)
@@ -18,6 +18,7 @@ PKG_SOURCE_SUBDIR:=opkg-$(PKG_VERSION)
 PKG_SOURCE_URL:=http://opkg.googlecode.com/svn/trunk/
 PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
 PKG_FIXUP = libtool
+PKG_REMOVE_FILES = autogen.sh aclocal.m4
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/host-build.mk
@@ -53,13 +54,6 @@ CONFIGURE_ARGS += \
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/var/lock/opkg.lock
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               autoreconf -v --install || exit 1 \
-       );
-       $(call Build/Configure/Default)
-endef
-
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -91,11 +85,6 @@ HOST_CONFIGURE_ARGS+= \
        --with-opkgetcdir=/etc \
        --with-opkglockfile=/tmp/opkg.lock
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); autoreconf -v --install || exit 1)
-       $(call Host/Configure/Default)
-endef
-
 define Host/Compile
        $(MAKE) -C $(HOST_BUILD_DIR) CC="$(HOSTCC)" all
 endef