ppp: quote positional parameters when calling up/down scripts (closes: #5622)
[openwrt/openwrt.git] / package / ppp / Makefile
index 7d05db09af7b3133d5e35e81631c29e34a9b3db6..919e105bbb71b3da82ba65c3a9695f8710db8afb 100644 (file)
@@ -1,26 +1,21 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id$
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ppp
-PKG_VERSION:=2.4.3
-PKG_RELEASE:=7
+PKG_VERSION:=2.4.4
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
-PKG_MD5SUM:=848f6c3cafeb6074ffeb293c3af79b7c
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_MD5SUM:=183800762e266132218b204dfb428d29
 
-PKG_BUILDDEP:=libpcap linux-atm
+PKG_BUILD_DEPENDS:=libpcap
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -32,64 +27,79 @@ define Package/ppp/Default
 endef
 
 define Package/ppp
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=+kmod-ppp
   TITLE:=PPP daemon
-  DESCRIPTION:=\
-       This package contains the PPP (Point-to-Point Protocol) daemon.
   MENU:=1
 endef
 
+define Package/ppp/description
+ This package contains the PPP (Point-to-Point Protocol) daemon.
+endef
+
 define Package/ppp-mod-pppoa
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +linux-atm +kmod-pppoa
   TITLE:=PPPoA plugin
-  DESCRIPTION:=\
-       This package contains a PPPoA (PPP over ATM) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoa/description
+ This package contains a PPPoA (PPP over ATM) plugin for ppp.
 endef
 
 define Package/ppp-mod-pppoe
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp +kmod-pppoe
   TITLE:=PPPoE plugin
-  DESCRIPTION:=\
-       This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
+endef
+
+define Package/ppp-mod-pppoe/description
+ This package contains a PPPoE (PPP over Ethernet) plugin for ppp.
 endef
 
 define Package/ppp-mod-radius
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=RADIUS plugin
-  DESCRIPTION:=\
-       This package contains a RADIUS (Remote Authentication Dial-In User \\\
-       Service) plugin for ppp.
+endef
+
+define Package/ppp-mod-radius/description
+ This package contains a RADIUS (Remote Authentication Dial-In User 
+ Service) plugin for ppp.
 endef
 
 define Package/chat
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Establish conversation with a modem
-  DESCRIPTION:=\
-       This package contains an utility to establish conversation with other \\\
-       PPP servers (via a modem).
+endef
+
+define Package/chat/description
+ This package contains an utility to establish conversation with other 
+ PPP servers (via a modem).
 endef
 
 define Package/pppdump
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Read PPP record file
-  DESCRIPTION:=\
-       This package contains an utility to read PPP record file.
+endef
+
+define Package/pppdump/description
+ This package contains an utility to read PPP record file.
 endef
 
 define Package/pppstats
-  $(call Package/ppp/Default)
+$(call Package/ppp/Default)
   DEPENDS:=ppp
   TITLE:=Report PPP statistics
-  DESCRIPTION:=\
-       This package contains an utility to report PPP statistics.
 endef
 
+define Package/pppstats/description
+ This package contains an utility to report PPP statistics.
+endef
+
+
 define Build/Configure
 $(call Build/Configure/Default,, \
        UNAME_S="Linux" \
@@ -110,65 +120,72 @@ define Build/Compile
                all install
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/pppd $(1)/usr/include/
+endef
+
 define Package/ppp/install
-       install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppd $(1)/usr/sbin/
-       install -d -m0755 $(1)/lib/network
-       install -m0755 ./files/ppp.sh $(1)/lib/network/
-       install -d -m0755 $(1)/etc/ppp
-       install -m0600 ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
-       install -m0644 ./files/etc/ppp/filter $(1)/etc/ppp/
-       install -m0755 ./files/etc/ppp/ip-up $(1)/etc/ppp/
-       install -d -m0755 $(1)/etc/ppp/ip-up.d
-       install -m0755 ./files/etc/ppp/ip-down $(1)/etc/ppp/
-       install -d -m0755 $(1)/etc/ppp/ip-down.d
-       install -m0644 ./files/etc/ppp/options $(1)/etc/ppp/
-       ln -sf /tmp/resolv.conf $(1)/etc/ppp/resolv.conf
+       $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppd $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/ppp.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_CONF) ./files/etc/ppp/chap-secrets $(1)/etc/ppp/
+       $(INSTALL_DATA) ./files/etc/ppp/filter $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files/etc/ppp/ip-up $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-up.d
+       $(INSTALL_BIN) ./files/etc/ppp/ip-down $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/ip-down.d
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-up $(1)/etc/ppp/
+       $(INSTALL_BIN) ./files/etc/ppp/ipv6-down $(1)/etc/ppp/
+       $(INSTALL_DATA) ./files/etc/ppp/options $(1)/etc/ppp/
+       ln -sf /tmp/resolv.conf.auto $(1)/etc/ppp/resolv.conf
 endef
        
 define Package/ppp-mod-pppoa/install
-       install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/pppoatm.so \
+       $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/pppoatm.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       install -d -m0755 $(1)/lib/network
-       install -m0755 ./files/pppoa.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pppoa.sh $(1)/lib/network/
 endef
 
 define Package/ppp-mod-pppoe/install
-       install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
+       $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/rp-pppoe.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       install -d -m0755 $(1)/lib/network
-       install -m0755 ./files/pppoe.sh $(1)/lib/network/
+       $(INSTALL_DIR) $(1)/lib/network
+       $(INSTALL_BIN) ./files/pppoe.sh $(1)/lib/network/
 endef
 
 define Package/ppp-mod-radius/install
-       install -d -m0755 $(1)/usr/lib/pppd/$(PKG_VERSION)
-       install -m0755 $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/radius.so \
+       $(INSTALL_DIR) $(1)/usr/lib/pppd/$(PKG_VERSION)
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/pppd/$(PKG_VERSION)/radius.so \
                $(1)/usr/lib/pppd/$(PKG_VERSION)/
-       install -d -m0755 $(1)/etc/ppp
-       install -m0644 ./files/etc/ppp/radius.conf $(1)/etc/ppp/
-       install -d -m0755 $(1)/etc/ppp/radius
-       install -m0644 ./files/etc/ppp/radius/dictionary* \
+       $(INSTALL_DIR) $(1)/etc/ppp
+       $(INSTALL_DATA) ./files/etc/ppp/radius.conf $(1)/etc/ppp/
+       $(INSTALL_DIR) $(1)/etc/ppp/radius
+       $(INSTALL_DATA) ./files/etc/ppp/radius/dictionary* \
                $(1)/etc/ppp/radius/
-       install -m0600 ./files/etc/ppp/radius/servers \
+       $(INSTALL_CONF) ./files/etc/ppp/radius/servers \
                $(1)/etc/ppp/radius/
 endef
 
 define Package/chat/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/chat $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/chat $(1)/usr/sbin/
 endef
 
 define Package/pppdump/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppdump $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppdump $(1)/usr/sbin/
 endef
 
 define Package/pppstats/install
-       install -d -m0755 $(1)/usr/sbin
-       install -m0755 $(PKG_INSTALL_DIR)/usr/sbin/pppstats $(1)/usr/sbin/
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/pppstats $(1)/usr/sbin/
 endef
 
 $(eval $(call BuildPackage,ppp))