move package description to a separate definition, remove it when DESCRIPTION=TITLE
[openwrt/openwrt.git] / package / shfs / Makefile
index 086a538319bcc4a3a93ab45a44c1509f6e9ead5e..a5ee79b05ea77907ddbeb432fdf9dc6832885877 100644 (file)
@@ -21,34 +21,40 @@ include $(INCLUDE_DIR)/package.mk
 
 define Package/shfs/Default
   TITLE:=ShFS
-  DESCRIPTION:=\
-       ShFS is a simple and easy to use Linux kernel module which allows you to \\\
-       mount remote filesystems using a plain shell (SSH) connection. When using \\\
-       ShFS, you can access all remote files just like the local ones, only the \\\
-       access is governed through the transport security of SSH.
   URL:=http://shfs.sourceforge.net/
 endef
 
+define Package/shfs/Default/description
+ ShFS is a simple and easy to use Linux kernel module which allows you to 
+ mount remote filesystems using a plain shell (SSH) connection. When using 
+ ShFS, you can access all remote files just like the local ones, only the 
+ access is governed through the transport security of SSH.
+endef
+
 define KernelPackage/shfs
-  $(call Package/shfs/Default)
+$(call Package/shfs/Default)
   TITLE+= (kernel module)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
   SUBMENU:=Filesystems
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef
 
+define KernelPackage/shfs/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS kernel module.
+endef
+
 define Package/shfs-utils
-  $(call Package/shfs/Default)
+$(call Package/shfs/Default)
   SECTION:=utils
   CATEGORY:=Utilities
   DEPENDS+=+kmod-shfs
   TITLE+= (utilities)
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the ShFS utilities.
+endef
+
+define Package/shfs-utils/description
+$(call Package/shfs/Default/description)
+ This package contains the ShFS utilities.
 endef
 
 define Build/Compile