procd: compile with LTO enabled
[openwrt/openwrt.git] / package / system / procd / Makefile
index c989ad660a837de12d226ba8bb73d677c59f4dcc..743352777466894bfb82499dda3c3c6c5c39c5a3 100644 (file)
@@ -37,6 +37,9 @@ endif
 CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 
+TARGET_CFLAGS += -flto
+TARGET_LDFLAGS += -flto
+
 define Package/procd
   SECTION:=base
   CATEGORY:=Base system