Group input devices under /dev/input
[openwrt/openwrt.git] / package / udev / Makefile
index 830ea6a6641aa7857c05a4c758e31d9f68ea336c..336e511f070dfbd8be9924e13de14719ea08e374 100644 (file)
@@ -9,21 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=udev
-PKG_VERSION:=077
+PKG_VERSION:=106
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.de.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       ftp://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/ \
-       http://ftp.fr.kernel.org/pub/linux/utils/kernel/hotplug/
-PKG_MD5SUM:=61ec646daf7795e9777e8f33975408fe
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/hotplug/
+PKG_MD5SUM:=320ccd2d0f4540d10e021bafa14f8985
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -32,20 +23,33 @@ define Package/udev
   CATEGORY:=Utilities
   DEPENDS:=@LINUX_2_6
   TITLE:=Dynamic device management subsystem
-  DESCRIPTION:=\
-       udev provides a dynamic device directory containing only the files for \\\
-       actually present devices. It creates or removes device node files in \\\
-       the /dev directory, or it renames network interfaces.
   URL:=http://www.kernel.org/pub/linux/utils/kernel/hotplug/udev.html
 endef
 
+define Package/udev/description
+ udev provides a dynamic device directory containing only the files for 
+ actually present devices. It creates or removes device node files in 
+ the /dev directory, or it renames network interfaces.
+endef
+
+define Package/udevtrigger
+$(call Package/udev)
+  TITLE:=Small utility to request kernel devices events for coldplug
+endef
+
+define Package/udev-vol-id
+$(call Package/udev)
+ TITLE:=Small utility to read volume ids
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
-               CROSS="$(TARGET_CROSS)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
                STRIP="/bin/true" \
                OPTFLAGS="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                INSTALL="install -c" \
+               EXTRAS="extras/volume_id" \
                all install
 endef
 
@@ -54,16 +58,29 @@ define Package/udev/install
        $(CP) $(PKG_INSTALL_DIR)/etc/udev/* $(1)/etc/udev/
        install -d -m0775 $(1)/lib/udev
        install -d -m0775 $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udev $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevsend $(1)/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/sbin/udevstart $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevcontrol $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevd $(1)/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevsettle $(1)/sbin/
        install -d -m0775 $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udevinfo $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/udevtest $(1)/usr/bin/
        install -d -m0775 $(1)/usr/sbin/
-       $(CP) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/udevmonitor $(1)/usr/sbin/
+       install -d -m0775 $(1)/etc/udev/rules.d
+       $(CP) files/20-input-grouping.rules $(1)/etc/udev/rules.d/
+endef
+
+define Package/udevtrigger/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/udevtrigger $(1)/sbin/
+endef
+define Package/udev-vol-id/install
+       $(INSTALL_DIR) $(1)/sbin
+       $(INSTALL_DIR) $(1)/lib
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/libvolume_id.so* $(1)/lib/
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/lib/udev/vol_id $(1)/sbin/
 endef
 
 $(eval $(call BuildPackage,udev))
+$(eval $(call BuildPackage,udevtrigger))
+$(eval $(call BuildPackage,udev-vol-id))