add a '@KERNEL' download facility, tweak script
[openwrt/openwrt.git] / package / util-linux / Makefile
index 43d7f7fb92a30875fcb4018801f62bd955532245..810a0936771ed201b0b079b70bb2f9f09e01828b 100644 (file)
@@ -13,10 +13,7 @@ PKG_VERSION:=2.12r
 PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       ftp://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/ \
-       http://ftp.de.kernel.org/pub/linux/utils/$(PKG_NAME)/
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/
 PKG_MD5SUM:=c261230b27fc0fbcc287c76884caf2d3
 
 include $(INCLUDE_DIR)/package.mk
@@ -30,30 +27,33 @@ endef
 define Package/fdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
-       This package contains an utility for managing disk partition tables.
+       This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
 define Package/cfdisk
   $(call Package/util-linux/Default)
   TITLE:=Partition table manipulation utility
-  DEPENDS:=+libncurses
+  DEPENDS:=+libncurses @!LINUX_2_6_ETRAX
   DESCRIPTION:=\
-       This package contains an utility for managing disk partition tables.
+       This package contains a utility for managing disk partition tables.
   URL:=http://www.kernel.org/pub/linux/utils/util-linux/
 endef
 
 define Package/losetup
   $(call Package/util-linux/Default)
   TITLE:=Loopback devices setup and control utility
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
-       This package contains an utility for managing loopback devices.
+       This package contains a utility for managing loopback devices.
 endef
 
 define Package/swap-utils
   $(call Package/util-linux/Default)
   TITLE:=Swap space management utilities
+  DEPENDS:=@!LINUX_2_6_ETRAX
   DESCRIPTION:=\
        This package contains a collection of tools for managing swap space: \\\
        - mkswap\\\
@@ -61,6 +61,14 @@ define Package/swap-utils
        - swapoff
 endef
 
+define Package/hwclock
+  $(call Package/util-linux/Default)
+  TITLE:=Utilities for managing the hardware clock
+  DEPENDS:=@!LINUX_2_6_ETRAX
+  DESCRIPTION:=\
+        This package contains a utility for managing the hardware clock
+endef
+
 TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/lib
 define Build/Compile
        $(call Build/Compile/Default, \
@@ -98,7 +106,12 @@ define Package/swap-utils/install
        $(call Package/Template,sbin/swapoff,$(1)/usr/sbin)
 endef
 
+define Package/hwclock/install
+       $(call Package/Template,sbin/hwclock,$(1)/usr/sbin)
+endef
+
 $(eval $(call BuildPackage,fdisk))
 $(eval $(call BuildPackage,cfdisk))
 $(eval $(call BuildPackage,losetup))
 $(eval $(call BuildPackage,swap-utils))
+$(eval $(call BuildPackage,hwclock))