busybox: add alternatives specs for those also provided by procps-ng
[openwrt/openwrt.git] / package / utils / busybox / Makefile
index a65f44f8fe0448ca34c1e72919c8d386e2e67865..a3012da7d47f2a892db51d85f1c1447d3c0da28c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.23.2
-PKG_RELEASE:=1
+PKG_VERSION:=1.26.2
+PKG_RELEASE:=6
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads \
-               http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=7925683d7dd105aabe9b6b618d48cc73
+PKG_SOURCE_URL:=https://www.busybox.net/downloads \
+               http://sources.buildroot.net
+PKG_HASH:=da3e44913fc1a9c9b7c5337ea5292da518683cbff32be630777f565d6036af16
 
 PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc BUSYBOX_CONFIG_PAM:libpam
 PKG_BUILD_PARALLEL:=1
@@ -27,7 +27,7 @@ PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
 include $(INCLUDE_DIR)/package.mk
 
 ifeq ($(DUMP),)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | mkhash md5)
 endif
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
@@ -39,11 +39,24 @@ endif
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
-  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+  MAINTAINER:=Felix Fietkau <nbd@nbd.name>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
-  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam
+  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
   MENU:=1
+  ALTERNATIVES:=\
+    $(if $(CONFIG_BUSYBOX_DEFAULT_KILL),       100:/bin/kill:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_PS),         100:/bin/ps:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_WATCH),      100:/bin/watch:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_IP),         100:/sbin/ip:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_FREE),       100:/usr/bin/free:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_PGREP),      100:/usr/bin/pgrep:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_PKILL),      100:/usr/bin/pkill:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_PMAP),       100:/usr/bin/pmap:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_PWDX),       100:/usr/bin/pwdx:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_TOP),                100:/usr/bin/top:/bin/busybox) \
+    $(if $(CONFIG_BUSYBOX_DEFAULT_UPTIME),     100:/usr/bin/uptime:/bin/busybox) \
+
 endef
 
 define Package/busybox/description
@@ -57,6 +70,9 @@ endef
 
 BUSYBOX_SYM=$(if $(CONFIG_BUSYBOX_CUSTOM),CONFIG,DEFAULT)
 
+# don't create a version string containing the actual timestamp
+export KCONFIG_NOTIMESTAMP=1
+
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
        grep 'CONFIG_BUSYBOX_$(BUSYBOX_SYM)' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_$(BUSYBOX_SYM)_\\(.*\\),\\1CONFIG_\\2,g" > $(PKG_BUILD_DIR)/.config
@@ -82,6 +98,12 @@ ifdef CONFIG_BUSYBOX_CONFIG_PAM
   LDLIBS += pam pam_misc pthread
 endif
 
+ifdef CONFIG_BUSYBOX_DEFAULT_NSLOOKUP_LEDE
+  ifeq ($(CONFIG_USE_GLIBC),y)
+       LDLIBS += resolv
+  endif
+endif
+
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -109,9 +131,13 @@ endef
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
+endif
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
        $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
+endif
        -rm -rf $(1)/lib64
 endef