busybox: alternatives: accomodate CONFIG_BUSYBOX_CUSTOM=y
[openwrt/openwrt.git] / package / utils / busybox / Makefile
index 59a84a2f94592dda075299296f916ed16bf712be..ebc824e4351f3018dc887039735b730db27b47ab 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2014 OpenWrt.org
+#
+# Copyright (C) 2006-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,26 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
-PKG_VERSION:=1.22.1
-PKG_RELEASE:=3
+PKG_VERSION:=1.26.2
+PKG_RELEASE:=7
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://www.busybox.net/downloads \
-               http://distfiles.gentoo.org/distfiles/
-PKG_MD5SUM:=337d1a15ab1cb1d4ed423168b1eb7d7e
+PKG_SOURCE_URL:=https://www.busybox.net/downloads \
+               http://sources.buildroot.net
+PKG_HASH:=da3e44913fc1a9c9b7c5337ea5292da518683cbff32be630777f565d6036af16
 
 PKG_BUILD_DEPENDS:=BUSYBOX_USE_LIBRPC:librpc BUSYBOX_CONFIG_PAM:libpam
 PKG_BUILD_PARALLEL:=1
 PKG_CHECK_FORMAT_SECURITY:=0
 
-PKG_LICENSE:=GPLv2 BSD-4c
+PKG_LICENSE:=GPL-2.0
 PKG_LICENSE_FILES:=LICENSE archival/libarchive/bz/LICENSE
 
 include $(INCLUDE_DIR)/package.mk
 
 ifeq ($(DUMP),)
-  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell $(SH_FUNC) grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | md5s)
+  STAMP_CONFIGURED:=$(strip $(STAMP_CONFIGURED))_$(shell grep '^CONFIG_BUSYBOX_' $(TOPDIR)/.config | mkhash md5)
 endif
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
@@ -36,14 +36,30 @@ else
   BB_MAKE_VERBOSE :=
 endif
 
+BUSYBOX_SYM=$(if $(CONFIG_BUSYBOX_CUSTOM),CONFIG,DEFAULT)
+BUSYBOX_IF_ENABLED=$(if $(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_$(1)),$(2))
+
 define Package/busybox
   SECTION:=base
   CATEGORY:=Base system
-  MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+  MAINTAINER:=Felix Fietkau <nbd@nbd.name>
   TITLE:=Core utilities for embedded Linux
   URL:=http://busybox.net/
-  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam
+  DEPENDS:=+BUSYBOX_USE_LIBRPC:librpc +BUSYBOX_CONFIG_PAM:libpam +BUSYBOX_CONFIG_NTPD:jsonfilter
   MENU:=1
+  ALTERNATIVES:=\
+    $(call BUSYBOX_IF_ENABLED,KILL,    100:/bin/kill:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,PS,      100:/bin/ps:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,WATCH,   100:/bin/watch:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,IP,      100:/sbin/ip:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,FREE,    100:/usr/bin/free:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,PGREP,   100:/usr/bin/pgrep:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,PKILL,   100:/usr/bin/pkill:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,PMAP,    100:/usr/bin/pmap:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,PWDX,    100:/usr/bin/pwdx:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,TOP,     100:/usr/bin/top:/bin/busybox) \
+    $(call BUSYBOX_IF_ENABLED,UPTIME,  100:/usr/bin/uptime:/bin/busybox) \
+
 endef
 
 define Package/busybox/description
@@ -55,7 +71,8 @@ define Package/busybox/config
        source "$(SOURCE)/Config.in"
 endef
 
-BUSYBOX_SYM=$(if $(CONFIG_BUSYBOX_CUSTOM),CONFIG,DEFAULT)
+# don't create a version string containing the actual timestamp
+export KCONFIG_NOTIMESTAMP=1
 
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
@@ -69,10 +86,6 @@ define Build/Configure
                oldconfig
 endef
 
-ifdef CONFIG_GCC_VERSION_LLVM
-  TARGET_CFLAGS += -fnested-functions
-endif
-
 LDLIBS:=m crypt
 ifdef CONFIG_BUSYBOX_USE_LIBRPC
   TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include
@@ -86,6 +99,12 @@ ifdef CONFIG_BUSYBOX_CONFIG_PAM
   LDLIBS += pam pam_misc pthread
 endif
 
+ifdef CONFIG_BUSYBOX_DEFAULT_NSLOOKUP_LEDE
+  ifeq ($(CONFIG_USE_GLIBC),y)
+       LDLIBS += resolv
+  endif
+endif
+
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
@@ -113,9 +132,13 @@ endef
 define Package/busybox/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(CP) $(PKG_INSTALL_DIR)/* $(1)/
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_CROND),)
        $(INSTALL_BIN) ./files/cron $(1)/etc/init.d/cron
-       $(INSTALL_BIN) ./files/telnet $(1)/etc/init.d/telnet
+endif
+ifneq ($(CONFIG_BUSYBOX_$(BUSYBOX_SYM)_NTPD),)
        $(INSTALL_BIN) ./files/sysntpd $(1)/etc/init.d/sysntpd
+       $(INSTALL_BIN) ./files/ntpd-hotplug $(1)/usr/sbin/ntpd-hotplug
+endif
        -rm -rf $(1)/lib64
 endef