f2fs-tools: fix mkfs.f2fs on big-endian systems
[openwrt/openwrt.git] / package / utils / f2fs-tools / Makefile
index adafcff9e022de64a73dec3562125acafafe4782..8a27c47adf13a1507de8594e53fe569a0f5862cf 100644 (file)
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=f2fs-tools
 PKG_VERSION:=1.8.0
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_LICENSE:=GPLv2
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
-PKG_HASH:=34790bccd74086e6b4f04fcac3a167ce1ca3319ce660454bceefc45c52906f94
+PKG_HASH:=d4dbecf55560c548bf0758c9f641d1beec1e960b38cbbc19951195d5144d39ae
 
 PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
@@ -59,6 +59,9 @@ endef
 CONFIGURE_ARGS += \
        --without-selinux
 
+CONFIGURE_VARS += \
+       ac_cv_file__git=no
+
 define Package/libf2fs/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) \