f2fs-tools: Update to 1.12.0
[openwrt/openwrt.git] / package / utils / f2fs-tools / Makefile
index 4ef751a5ff1078ad35aa8a4bf52c67d806f42876..b782b806704b15aa727e00297b10634fbf91d3e7 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=f2fs-tools
-PKG_VERSION:=1.8.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.12.0
+PKG_RELEASE:=1
 
 PKG_LICENSE:=GPLv2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git/snapshot/
-PKG_HASH:=d4dbecf55560c548bf0758c9f641d1beec1e960b38cbbc19951195d5144d39ae
+PKG_HASH:=e2124e4dffaba865d41495d817bcb924d096adaec67ff777b8c7da99aa13f696
 
 PKG_FIXUP:=autoreconf
 PKG_BUILD_PARALLEL:=1
@@ -57,7 +57,11 @@ define Package/libf2fs
 endef
 
 CONFIGURE_ARGS += \
-       --without-selinux
+       --without-selinux \
+       --without-blkid
+
+CONFIGURE_VARS += \
+       ac_cv_file__git=no
 
 define Package/libf2fs/install
        $(INSTALL_DIR) $(1)/usr/lib