px5g: Fix TARGET_LDFLAGS and add TARGET_CPPFLAGS
[openwrt/openwrt.git] / package / utils / px5g / Makefile
index e924ab30fb049c913ff9b6d581896d56954253b3..8d1f04d60fb8403d4b50fc0ec469eedc7f0062eb 100644 (file)
@@ -14,49 +14,57 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/px5g-$(BUILD_VARIANT)
 
 PKG_USE_MIPS16:=0
 
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
+
 include $(INCLUDE_DIR)/package.mk
 
-define Package/px5g/Template
+define Package/px5g-mbedtls
   SECTION:=utils
   CATEGORY:=Utilities
-  TITLE:=X.509 certificate generator (using $(1))
-  MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-  DEPENDS:=+lib$(1)
+  SUBMENU:=Encryption
+  TITLE:=X.509 certificate generator (using mbedtls)
+  DEPENDS:=+libmbedtls
   PROVIDES:=px5g
-  VARIANT:=$(1)
+  VARIANT:=mbedtls
 endef
 
-define Package/px5g-polarssl/description
+define Package/px5g-mbedtls/description
  Px5g is a tiny standalone X.509 certificate generator.
  It suitable to create key files and certificates in DER
  and PEM format for use with stunnel, uhttpd and others.
 endef
 
-Package/px5g-mbedtls=$(call Package/px5g/Template,mbedtls)
-Package/px5g-polarssl=$(call Package/px5g/Template,polarssl)
-Package/px5g-mbedtls/description=$(Package/px5g-polarssl/description)
+define Package/px5g-standalone
+  SECTION:=utils
+  CATEGORY:=Utilities
+  SUBMENU:=Encryption
+  TITLE:=X.509 certificate generator (standalone)
+  VARIANT:=standalone
+endef
+Package/px5g-standalone/description = $(Package/px5g-mbedtls/description)
 
 define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
 
-ifeq ($(BUILD_VARIANT),mbedtls)
-TARGET_CFLAGS += -DMBEDTLS
-TARGET_LDFLAGS := -lmbedtls -lmbedx509 -lmbedcrypto
-else
-TARGET_LDFLAGS := -lpolarssl
+TARGET_LDFLAGS += -lmbedtls -lmbedx509 -lmbedcrypto
+
+ifeq ($(BUILD_VARIANT),standalone)
+  TARGET_LDFLAGS := -Wl,-Bstatic $(TARGET_LDFLAGS) -Wl,-Bdynamic
 endif
 
+TARGET_CFLAGS += -Wl,--gc-sections
+
 define Build/Compile
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)
+       $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g.c $(TARGET_LDFLAGS)
 endef
 
-define Package/px5g-polarssl/install
+define Package/px5g-mbedtls/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/px5g $(1)/usr/sbin/px5g
 endef
 
-Package/px5g-mbedtls/install=$(Package/px5g-polarssl/install)
+Package/px5g-standalone/install = $(Package/px5g-mbedtls/install)
 
-$(eval $(call BuildPackage,px5g-polarssl))
 $(eval $(call BuildPackage,px5g-mbedtls))
+$(eval $(call BuildPackage,px5g-standalone))