the default_subtargets template was a bad idea, since different makefiles require...
[openwrt/openwrt.git] / rules.mk
index 2dc8bcc7ccdff46f6374cd7131e1a40cac7ef60b..0ce75f55c0c5dea4be0bd8c572b99aa645658724 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -131,27 +131,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-# Default targets for subdirectory calls
-# Parameters:
-#      1: dependencies for the prepare step
-define default_subtargets
-  %-download: FORCE
-       $$(MAKE) -C $$(patsubst %-download,%,$$@) download
-
-  %-prepare: $(1) FORCE
-       $$(MAKE) -C $$(patsubst %-prepare,%,$$@) prepare
-
-  %-compile: %-prepare 
-       $$(MAKE) -C $$(patsubst %-compile,%,$$@) compile
-
-  %-install: %-compile
-       $$(MAKE) -C $$(patsubst %-install,%,$$@) install
-
-  %-clean: FORCE
-       @$$(MAKE) -C $$(patsubst %-clean,%,$$@) clean
-endef
-
-
 all:
 FORCE: ;
 .PHONY: FORCE