add a stripped down (and portable) version of flock to the host tools
[openwrt/openwrt.git] / rules.mk
index c0004d808832ae3a2c85a7c94efe44a5affac1c9..23445bfaeed6d7a2642a1cd55becec9895fa5d0e 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -47,6 +47,8 @@ else
   FPIC:=-fpic
 endif
 
+HOST_FPIC:=-fPIC
+
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
@@ -160,7 +162,7 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
-PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
+KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 LN:=ln -sf
@@ -254,4 +256,16 @@ all:
 FORCE: ;
 .PHONY: FORCE
 
+val.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo '$(subst ','"'"',$($*))' \
+       )
+
+var.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo "$*='"'$(subst ','"'\"'\"'"',$($*))'"'" \
+       )
+
 endif #__rules_inc