add $(STAGING_DIR)/host, which contains target specific, but host executable files
[openwrt/openwrt.git] / rules.mk
index 1986097bad326d72facc47be11b548983b7b3b11..2f528162f4ed13f04387a1716f19fa9096bcb18b 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -56,7 +56,7 @@ ifeq ($(CONFIG_NATIVE_TOOLCHAIN),)
   TARGET_CROSS:=$(if $(TARGET_CROSS),$(TARGET_CROSS),$(OPTIMIZE_FOR_CPU)-linux-uclibc-)
 endif
 
-TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(PATH)
+TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
 TARGET_CFLAGS:=$(TARGET_OPTIMIZATION) -fhonour-copts
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS:=-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib