don't overwrite .config if it's a symlink (fixes scripts/env problems)
[openwrt/openwrt.git] / rules.mk
index 5df9c034dbf777be834da15797158436491bd23a..614feb6fc5f0fa81c3f6c1f7bb9d5625f7903237 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -1,9 +1,10 @@
-# 
-# Copyright (C) 2006-2007 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
+# $Id$
 
 ifneq ($(__rules_inc),1)
 __rules_inc=1
@@ -63,7 +64,7 @@ TARGET_DIR:=$(BUILD_DIR)/root-$(BOARD)
 IPKG_STATE_DIR:=$(TARGET_DIR)/usr/lib/ipkg
 
 TARGET_PATH:=$(TOOLCHAIN_DIR)/bin:$(STAGING_DIR_HOST)/bin:$(STAGING_DIR)/host/bin:$(PATH)
-TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)
+TARGET_CFLAGS:=$(TARGET_OPTIMIZATION)$(if $(CONFIG_DEBUG), -g3)
 TARGET_CPPFLAGS:=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
 TARGET_LDFLAGS:=-L$(TOOLCHAIN_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
 
@@ -129,7 +130,7 @@ TARGET_CONFIGURE_OPTS:= \
   SIZE=$(TARGET_CROSS)size
 
 # strip an entire directory
-ifneq ($(CONFIG_BUILD_DEVELOPER_SYSTEM),)
+ifneq ($(CONFIG_NO_STRIP),)
   RSTRIP:=:
 else
   RSTRIP:= \