remove ARCH:=i686 from s100 profile - the build system can't handle that properly yet
[openwrt/openwrt.git] / rules.mk
index b63fcf31c8f5f7a6934473e64992f4188263599c..6fbf88f801f21113335ed2e733670d966479d447 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -5,7 +5,9 @@
 # See /LICENSE for more information.
 #
 
--include $(TOPDIR)/.config
+ifeq ($(DUMP),)
+  -include $(TOPDIR)/.config
+endif
 include $(TOPDIR)/include/verbose.mk
 
 export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
@@ -83,12 +85,15 @@ TARGET_CONFIGURE_OPTS:= \
   CXX=$(TARGET_CROSS)g++ \
   RANLIB=$(TARGET_CROSS)ranlib \
   STRIP=$(TARGET_CROSS)strip \
-  OBJCOPY=$(TARGET_CROSS)objcopy
+  OBJCOPY=$(TARGET_CROSS)objcopy \
+       OBJDUMP=$(TARGET_CROSS)objdump \
+       SIZE=$(TARGET_CROSS)size
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
@@ -129,7 +134,6 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
-
 all:
 FORCE: ;
 .PHONY: FORCE