rename the Profile template that the image builder uses to prevent name conflicts...
[openwrt/openwrt.git] / rules.mk
index 3afdab67c2822c4a3a2925c326ef580363dd7486..a6188f4a6baaffc1aa5f5651af6a7e9d1e6fe903 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -69,6 +69,10 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
+EXTRA_CPPFLAGS := -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include
+EXTRA_CFLAGS := $(EXTRA_CPPFLAGS)
+EXTRA_LDFLAGS := -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
@@ -83,6 +87,7 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
   STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh